Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

it's my first post here, don't wanna make it long, but I got a problem with my 'Windows Update' it won't show its setting's options. It only shows these settings: Important Updates, Recommended Updates and Who can install updates, it removed the other setting sections like 'Microsoft Updates' "Give me updates for Microsoft products and check for new optional Microsoft software when I update windows" or the last settings section 'Software notification' "Show me detailed notifications when new Microsoft software is available"

Here's a screenshot of my Windows Update:

enter image description here

And here's how it was before and how should be:

enter image description here

PS: I'm running windows 7 RTM

share|improve this question
    
When did this change? What things have you changed in between the last time it looked right and now? –  GAThrawn Feb 11 '11 at 17:36
    
Well, i was trying to install a Wireless Printer(it is on Workgroup) but the installing process searches for Drivers also on Windows Update and this search takes a long time, so i decided to uncheck this option on Windows Update settings: "Give me updates for Microsoft products..." and then set it to "Never check for updates(not recommended)" with a word to turn it off, but then when i tried to turn it on the settings i had before then the problem started, by removing those setting's options(like cited on my prob description)img209.imageshack.us/img209/3379/windowsprinterinstallat.png –  user12861 Feb 11 '11 at 17:36

2 Answers 2

The seems very similar to the behavior that Microsoft introduced to their Windows Update website a few years ago when they rolled out Windows Genuine Advantage. They decided to allow non-genuine copies of Windows (read “pirated copies”) to receive important and critical updates so that those systems that exist anyway would be patched and help reduce problems on the Internet as a whole. However they also made it so that non-genuine copies would be blocked from receiving optional and value-added updates (like drivers, games, media player, etc.) since they are not critical to preventing worms and DDoS from spreading.

You may have somehow triggered WGA to detect your system as either non-genuine, or not-verified. Run the Genuine Advantage tool to verify your system. You could also try to download something from Microsoft Downloads that requires verifying your system as genuine (you don’t actually have to download, just get past the genuine check). Also, make sure to use IE since it uses the Active-X component to check, whereas other browsers use a standalone app which may not toggle the flag in the system. (It seems like every other file requires verification, but now that I am actually looking for one… anyway, here’s and example).

That should set Microsoft Updates back to normal.

share|improve this answer

Have you checked group policy editor? Type gpedit.msc in the start menu. Then expand Computer configuration > Administrative templates > Windows components and click Windows update. In the right pane make sure all items are set to Not Configured.

share|improve this answer
    
Just checked that, and everything is set to "Not Configured" Thanks. –  user12861 Sep 30 '09 at 22:59
    
Is it a local computer or are you a member of a domain? –  CGA Sep 30 '09 at 23:01
    
No, I'm not a memeber of a domain.THNX –  user12861 Sep 30 '09 at 23:02
    
Hmmm, I'm stumped. –  CGA Sep 30 '09 at 23:05
    
Me too, :) and i dunno wut to do? –  user12861 Sep 30 '09 at 23:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.