Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Why does the Internet WI-FI connection of my laptop disconnect when I connect the ethernet cable to the LAN?

These are two separate networks, the LAN is without Internet, I just use it to connect the tablet to the laptop and smart phone in my home network.

The WI-FI is owned by the landlady and connects to the Internet.

I know it should be possible to be connected both to the Internet through WI-FI and to my other computers and gadgets through the LAN because sometimes it works, but sometimes when I connect the ethernet cable the WI-FI disconnects and I wonder why?

Pongy

OS: Windows 7

share|improve this question
    
1  
@CharlieRB - This is not a duplicate - that's asking how to prioritize one connection over the other, while this is saying that Joey can't connect both at the same time. –  Shinrai Oct 26 '12 at 14:31
1  
Shinrai, you're right. Anyone knows the answer to this question? –  Joey Hammer Oct 26 '12 at 15:34
    
What kind of notebook is it? Many of them come with a manufacturer's utility to do this on purpose. Does it do it in Safe Mode with Networking? What have you tried already? –  Ƭᴇcʜιᴇ007 Oct 27 '12 at 3:55
    
It's a Sony Vaio VPCEA3S1E (i3, Win7). Have tried fiddling with the DHCP, DNS, IPv4 settings, ipconfig /relese, ipconfig /renew, unplugging, rewiring. It worked yesterday, today not. The internet through wi-fi connection works but when I plug in the ethernet cable to the LAN it ceases to work. Funny thing is, it's just Chrome and IE etc that cannot connect anymore, Skype is still connected and some other softwares as well. –  Joey Hammer Oct 27 '12 at 8:57

2 Answers 2

This is almost certainly due to a security policy. Windows is perfectly capable of operating wired and wireless connection simultaneously but most corporate systems impose a policy whereby, if the wire is connected, the wireless will disconnect.

In this case it is not a corporate laptop but the policy is also often imposed when you use a third party utility to control the WiFi connections. Many laptops come with these pre-installed.

Check your security settings, both in Windows itself and the WiFi driver if it is a third party add on. If there is a third party add on and it appears to be the problem, try deleting it. Just use Windows itself to control the WiFi.

share|improve this answer

The problem is your computer has to have two IPs active at the same time, so it could be that your network and the land lady are giving you or some other device on the network the same IP address. That will cause all sorts of weird behavior. (like Chrome doesn't work and other things do) An easy fix is to change the DHCP on your router to be a different network. Like if the land lady gives you 192.168.1.x set your router for 192.168.2.x

The other problem could be that your computer is configured to automatically disconnect from the wireless when it senses a cable connection. I know my Toshiba does that. (Back when wireless was new I had a user that insisted on being wireless and wired. Unfortunately it didn't work worth a darn and caused all sorts of weird problems. My solution was to say "don't do that" I would have loved the auto-disconect feature. But that won't work for you. )

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.