Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7 32-bit, and have a Transcend 8 GB USB 2.0 flash drive. I have formatted the drive to NTFS using the Windows format tool.

The problem is that when moving or copying files to and from the drive I get write speeds of only 1.5 - 2.5 MB/s. I read articles on the net, and changed the caching policy to "better performance" and formatted to NTFS. Still no change.

How do I fix it?

UPD:

I meant NTFS.

My pen drives a Transcend JetFlash 500.

I used it on a different computer with Windows XP, and a particular 2.55 GB folder took 5 minutes to copy. The time to copy to my computer with Windows 7 was 6 minutes.

So I guess the problem is not with the reading, rather writing mostly.

I have read, people writing at 20MB/s.

So how do I optimize my writing speed?

share|improve this question
2  
I have never heard of ntsc you sure you don't mean ntfs? USB 2.0 is limited to around 1.5MB/s to 2.5MB/s it even might be a quality problem, not much you can do about that. –  Ramhound Oct 26 '12 at 14:17
2  
@Ramhound I'm not sure what you are talking about, USB 2.0 is good for 480Mbit/s or 35MB/s. It doesn't always get that fast, but it should be at least half that. Is the drive always this slow, or does it ever become faster? –  David Oct 26 '12 at 14:26
    
Rosso, did you test your Transcend pen drive faster on any other computer? Because there simple are a lot of slow pen drives out there. Some of the ones I tested manage 5MB/sec read and 3MB/sec write. –  Hennes Oct 26 '12 at 15:02
    
I meant NTFS. My pen drives a Transcend JetFlash 500. I used it on a different computer with Windows XP, and a particular 2.55 GB folder took 5 minutes to copy. The time to copy to my computer with Windows 7 was 6 minutes. So I guess the problem is not with the reading, rather writing mostly. I have read, people writing at 20MB/s. So how do I optimize my writing speed? –  Rosso Oct 29 '12 at 12:42
    
How much RAM do you have? If you don't have a lot of RAM, it will be slow –  Sylvester the Cat Oct 29 '12 at 23:32

3 Answers 3

In Device Manager, right-click the USB drive in the Disk drives category, then select Properties, switch to Policies tab, and choose "Optimize for performance". Click OK to keep it.

Note: If you use this method, make sure you use the "Safely remove hardware" icon that appears in the notification area when you plug in the device (the notification area is the little area near the clock on the taskbar).

share|improve this answer

With time, USB transfer speed decreases, or at least that has been the case with me.

This might help: http://www.sevenforums.com/hardware-devices/136565-very-slow-usb-transfer-rate-win-7-64-bit.html

share|improve this answer

Check your BIOS settings! Typically, you access your BIOS settings shortly after your turn on your PC by pressing the DEL key. Sometimes, this is the F2 key (like for most Dell's) or possibly something else.

Once in the BIOS, you may have a setting related to USB compatibility. And it could be that it's now set to "Legacy" mode which maxes out at something like 12MBps. This legacy mode may be necessary for some older USB devices (like certain modems that no one uses any more), but if you have no such devices then leaving it set to legacy mode makes no sense. Even if you have older USB devices, it's not likely that you need rock hard USB 1.x compatibility at the BIOS level. Therefore, you probably will want to change your BIOS settings with regard to USB compatibility and set it to the other setting, probably something like "full mode" so that your USB controller(s) can transfer data at rates up to 480MBps. Not that Windows Vista/7 will exactly let you go that fast, but it will definitely be better than 1 to 2MBps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.