Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Thank you for reading. I hope this is something simple I am overlooking.

Synopsis: I have a Word doc containing linked charts from a single Excel source. They are docx and xlsx files created in Word and Excel 2010 versions on a PC. I created the charts in Excel, copied and pasted into Word and selected "Keep Source Formatting and Link to Excel" from the clipboard popup. I wish to be able to switch the linked source file for all charts easily using Find and Replace on the Field Codes (feel free to suggest a better way).

Issue: When I try to display the Field Codes for the charts using ALT+F9 or View Field Codes button ({a}), nothing happens to the charts. No Field Codes appear, they just stay charts. I can see other field codes within the document but not for the charts.

I have tried: Using ALT+F9, using the View Field Codes button, checking and un-checking "Show field codes instead of their values" Under File > Options > Advanced.

I appreciate any clues!

share|improve this question
    
Can you clarify? It sounds like you are attempting to edit the source Excel data through the linked charts. Is that what you are saying? –  CharlieRB Oct 26 '12 at 19:59
    
@CharlieRB Hi, I am attempting to switch the Excel sheet the charts in Word are linked to, all at once. It can be accomplished through Word by going to File...Edit Links to Files, but that makes you select a new source for each chart individually, even if they are all the same source file. I'm not attempting to edit the charts themselves in Word. The best way I know to change all the sources in a more automated way (without VBscript) is to Find and Replace the source Excel in the Field Codes for the charts. However, I cannot seem to access the Field Codes to do it. Does that help? Thank you! –  outatime88 Oct 26 '12 at 20:23
add comment

1 Answer

up vote 1 down vote accepted

Okay, after much research, I finally just tried a different way of pasting the charts in. Instead of pasting using CTRL+V and using the clipboard popup to select "Keep Source Formatting and Link to Excel", I had to use the Home > Paste... Paste Special... menu option (or ALT+CTRL+V), then choose Paste link: Microsoft Excel Chart Object. I can toggle the field code visibility just fine for objects pasted in this way.

The pasted object seems to behave differently in Word, however. It re-sizes like a picture instead of a chart (stretches text). And the Chart Tools ribbon is not available when it is selected, but it will work for my needs.

Sorry I ended up (sort of) answering myself. Maybe this will help someone else. Thanks!

share|improve this answer
1  
Answering your own question is perfectly acceptable here. Thanks for coming back and sharing it so the next reader can use this answer. Good job! –  CharlieRB Oct 29 '12 at 15:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.