Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have my primary C Drive which consists of 2 Intel 120GB SSD Drives in a RAID0. I have a clean install of Windows 8 Pro, latest MEI software, latest RST software, latest Intel Toolbox. Prior to this I had installed Windows 8 Pro as an upgrade. When I went into the Optimize Drives while in the Upgrade installation, it showed the Media Types as Solid State Drives. However, now since I am in a brand new install, it is showing the Media Type as Hard Disk Drive.

I am worried about this because of the trim not working properly. Before when in the upgrade, it showed SSD as the media type and the Optimize option would perform a manual trim.

Unfortunately, my search credentials on Google are so common to many other things (ie Raid0, SSD, Windows 8, Media Type) that all I am finding are useless topics.

enter image description here

Before, (found on random site) it showed the Media Type as below

enter image description here

share|improve this question
I just updated the BIOS, installed the Suite for my motherboard (ASUS Sabertooth Z77) and still did not make a difference. – kobaltz Oct 27 '12 at 2:06
Disconnect your external HDD and then try to optimize. – avirk Oct 29 '12 at 2:31
Unfortunately, neither of those suggestions worked. – kobaltz Oct 29 '12 at 17:43
@kobaltz You had both drives running as RAID 0 in your Upgrade installation? – Django Reinhardt Oct 30 '12 at 14:17
up vote 5 down vote accepted

This died upgrading to Windows 8.1 for me.

The problem is caused by Microsoft WEI (Windows Experience Index) not being run (its even removed from the GUI in Windows 8.1).

To help Windows 8 and Windows 8.1 users, the core code that does this is still in Windows, but only accessible from the command line in 8.1.

To get the SSDs to be correctly listed:

1) Install the latest RST from Intel (currently 12.8 from Aug'13). 2) Go to an admin cmd prompt 3) Type: winsat prepop

This will run all the tests on the computer and reprofile it. This includes correctly tagging RAID0 SSDs.

Took me ages to find out how to fix this. Well worth sharing with everyone.

If you're keen you can limit the testing to just the disk, but why bother? Best get the whole computer back on track.

share|improve this answer
Thank you very much the "winsat prepop" fixed my speed issues I had with my Raid0 2xSSD. Probably fixed DMA/PIO issue i may had, but wasn't able to fix as I have no IDE/ATA item in my device manager. – Jiří Herník Feb 3 '15 at 14:58
I downgraded my previous laptop to an HDD from an SDD and after cloning Windows still thought it was an SSD. This solved the issue and now Windows correctly displays it as an HDD so I can happily defrag like the good 'ol days! – WiteCastle Mar 14 '15 at 0:57

According to Intel's website, TRIM is not supported for any RAID configurations at the moment:

TRIM support in Windows 7 [and 8] (in AHCI and RAID mode [only] for drives not part of a RAID volume)


That page is dated 04-Oct-2012, so pretty recent, too. Their latest SSD Toolbox FAQ supports this stance as well (see Q11).

Of course, Intel being Intel, this appears to be completely wrong, and they DO support TRIM in RAID 0 configurations (but only for 7 Series chipsets).

RST 11.2 supports TRIM on RAID 0 only on Intel Desktop Boards with the 7 Series chipsets.


And the following Anatech article details support for TRIM support in RAID 0:

The feature is limited to Intel 7 series chipsets with RST RAID support and currently only works on Windows 7 OSes, although Windows 8 support is forthcoming.


So it IS supported. Just not by Windows 8 at the moment.

Update: It appears Windows 8 RAID 0 TRIM is supported as of RST version Just make sure you install all the Windows 8 Updates before you unstall RST.

Good luck!

share|improve this answer
Here is an article with real data showing SSD RAID0 trim… – kobaltz Oct 30 '12 at 14:47
Stupid Intel website! Lol.According to that article, "The feature is limited to Intel 7 series chipsets with RST RAID support and currently only works on Windows 7 OSes, although Windows 8 support is forthcoming." So it's not supported by Windows 8 at the moment. I'm guessing your upgrade kept your Windows 7 drivers? – Django Reinhardt Oct 30 '12 at 14:48

I was able to fix the issue. I first installed a clean version of Windows 8 Pro. I performed the Windows updates and installed the normal driver software for my motherboard's chipset. Afterwards I confirmed that the Optimize Disks showed the drives as a solid state drive. However, since the Raid Controller software was not installed, they could not be trimmed. I then installed Intel RST 11.6.1030 and rebooted. After the reboot the Optimize Drives showed the RAID partition still as SSD and was able to Optimize the drive (perform trim).

share|improve this answer
So you did EXACTLY the same thing as before, but ended up with a different result? It sounds likely that you didn't have the latest RST drivers before, after all(?). – Django Reinhardt Nov 2 '12 at 4:08
Before, I did Windows Updates and installed Intel MEI. Not sure what or why it happened. I did have 11.6.1030 before as well. – kobaltz Nov 2 '12 at 12:22
So what did you do differently this time? It sounds like you did precisely the same thing in exactly the same order? – Django Reinhardt Nov 5 '12 at 18:45
Before I installed the drivers prior to Windows Update. Also, I did not install Intel MEI with the latest installation. – kobaltz Nov 5 '12 at 19:35

I ran into this issue as well. I did not succeed using the author's method. I re-installed to document everything at each step, so that everyone can see a step-by-step.

Motherboard: Z77X-UDH5
RAID OROM Version: 11.6

  1. Upgrade BIOS
    • MFG does not provide OROM 11.6, so I used z77xud5hMOD_10_16_12.15t
  2. Upgrade all SSD firmware
    • Upgraded OCZ Vectors to 2.0
  3. Secure Wipe all SSDs
  4. Set BIOS to use RAID mode
  5. Set up RAID array
  6. Install Windows 8 x64 Pro
    • Do not use F6 driver
  7. After Windows installation, "Optimize" shows up as "Solid State Drive"
  8. Install all available Windows updates
    • Reboot as needed
    • More updates after reboot.
  9. "Optimize" still shows "Solid State Drive"
  10. Install Intel RST 11.6
  11. "Optimize" now shows "Hard disk drive"

In all, I was unable to get the "Defragment and optimize your drives" tool to recognize the drives as solid state.

However, I did learn that the command defrag.exe C: /L will perform a force-trim of the entire disk. This is good enough, and Windows seems to permit it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .