Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Windows 8 upgrade installer is not working properly, every time I try to download the OS there is an error "The download task is not complete" "The specified service does not exist as an installed service". I already paid for it, it is pretty irritating that Something I paid for is not letting me install the services it provides. Can anyone help me?

share|improve this question
1  
"The specified service does not exist as an installed service" Try enabling the BITS service, WebClient service and Windows Update service; I suspect you have one of them not being able to start so that might be a first thing to troubleshoot. Tell me if it worked so I can put it as an answer. I really suspect it to be BITS because it's talking about a "download task" and that's kind of what BITS does, although its named Jobs there, but that shouldn't matter... – Tom Wijsman Oct 27 '12 at 2:13
    
I don't know how to enable the bits service. – zach Oct 27 '12 at 2:18
    
Start > Run > Services.msc > Double click BITS and set it to Automatic, then click Start, then Apply. – Tom Wijsman Oct 27 '12 at 2:26
    
I set bits to automatic then ran the installer again, yet it still gives me the same error. – zach Oct 27 '12 at 2:34
    
"I set bits to automatic" but is the status column showing "Running"? also check the other services Tom suggested. – Moab Oct 27 '12 at 2:40

Redownload the Windows 8 Upgrade Assistant. Your download may have been corrupt.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .