Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My home linksys router is using local address of 192.168.75.1 and subnet of 255.255.255.0. The DHCP server is enabled. The starting IP address is 192.168.75.100.

I'm facing problem configuring the IP of a host manually in windows 7. In LAN connection properties, I set the IP address to 192.168.75.103 and subnetmask to 255.255.255.0 under properties. I'm able to ping my other computer in the same network of 192.168.75.102 but I'm not getting connected to the internet. It works if i obtain IP address by DHCP.

here is my ipconfig /all info:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : codemonkey-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Contr
   Physical Address. . . . . . . . . : BC-5F-F4-5A-4C-92
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::e88c:7158:f66:eebe%11(P
   IPv4 Address. . . . . . . . . . . : 192.168.75.103(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.75.102
   DHCPv6 IAID . . . . . . . . . . . : 247226356
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-15-75-D5-BC-5F

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VMware Virtual Ethernet Adapt
1
   Physical Address. . . . . . . . . : 00-50-56-C0-00-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8c16:daae:dcd:bc5%14(Pr
   IPv4 Address. . . . . . . . . . . : 192.168.40.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 318787670
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-15-75-D5-BC-5F

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VMware Virtual Ethernet Adapt
8
   Physical Address. . . . . . . . . : 00-50-56-C0-00-08
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::b06d:ab4a:cc22:9c18%16(
   IPv4 Address. . . . . . . . . . . : 192.168.75.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 352342102
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-15-75-D5-BC-5F

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{51D31CD7-FC75-4997-AF4F-DA672D8E928C}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Inter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{0D8C0AC8-32A3-4856-A3D3-769BC8FB4140}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{30063663-D3EF-4349-958D-CFD822487C12}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
share|improve this question
    
1) The default gateway address should be the router's address, 192.168.75.1. 2) Statically assigned addresses should be outside the DHCP range, not inside it. For example, 192.168.75.71. –  David Schwartz Oct 27 '12 at 8:16

4 Answers 4

Try this:

1) Set it up (computer and router) to obtain ip address automatically.  
2) Shutdown computers.  
3) Power the router off then after 30 seconds, power back on.  
4) Repower computers.  
5) Confirm that you have Internet connectivity.  
6) Make note of (in router settings):  
   a) Subnet mask.  
   b) Wan IP Address.  
   c) Default Gateway Address.  
   d) DNS Address.  
   e) Client IP Addresses.  
7) Setup router to use Static IP addresses.  
8) Configure Windows for Manual (static) IP addresses.
9) Insure Gateway is set as 192.168.75.1 in Windows.  
10) Shutdown computers.  
11) Re-power router as in step 3.  
12) Re-power computers.  
13) Confirm router settings are the same as before:  
   a) Subnet mask.  
   b) Wan IP Address.  
   c) Default Gateway Address.  
   d) DNS Address.  
14) Confirm Client IP Addresses are as you configured in Windows.  
15) Confirm that you have Internet connectivity.  
share|improve this answer
    
hi what should i put for m dns addr?? –  nuttynibbles Oct 27 '12 at 7:17
    
@nuttynibbles step 6.d: make note of DNS address while connected with activated DHCP configuration. You should put that in. This solution will work, as basically with that, you copy the whole good DHCP config sans IP address... –  ppeterka Oct 27 '12 at 7:23
    
Hey tks alot. It works. Just how did windows generate the dns server ip? –  nuttynibbles Oct 27 '12 at 7:28
    
@nuttynibbles I'm not sure what you mean by "generate the dns server ip". If you're asking how windows could find the true (Internet) DNS IP address, I believe windows can discover this by querying the Gateway (router). –  Kevin Fegan Oct 28 '12 at 17:26

You've set your default gateway to your other PC, the one at 192.168.75.102. That's wrong. Set your default gateway to the IP address of your router, 192.168.75.1.

share|improve this answer
    
hi, yup i have tried 192.168.75.1 but still dont work. –  nuttynibbles Oct 27 '12 at 7:21

It's because you should manually set your default gateway to the gateway's address, (router in this case), so 192.168.75.1, and not 192.168.75.102.

In Win7, you can set this:

  1. Open Network Connections by clicking the Start button , clicking Control Panel, clicking Network and Internet, clicking Network and Sharing Center, and then clicking Manage network connections.

  2. Right-click the connection that you want to change, and then click Properties. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

  3. Click the Networking tab. Under This connection uses the following items, click either Internet Protocol Version 4 (TCP/IPv4) or Internet Protocol Version 6 (TCP/IPv6), and then click Properties.

Your computer has to know how to connect to the other networks, that's what the default gateway does.

share|improve this answer
    
hi i have changed the default gateway to 192.168.75.1 and it still wouldn't connect. actually the above ipconfig /all result ewas taken after i messed around with the default gateway to .102. i have tried the router gateway address earlier but still didnt work –  nuttynibbles Oct 27 '12 at 7:20

I think your problem is DNS. If you can ping external IP addresses, then your internet works. Try one of these:

8.8.8.8, 208.67.222.222, 173.194.71.94

In your ip-configuration dialog, set the DNS to that of the default gateway (router), or to an external public server such as open-dns (208.67.222.222).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.