Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi and forgive me if I am unclear in this question as I am trying to get back to development after my fourth brain surgery in 2 years so I feel a little groggy.

I am trying to set (and learn how to set up) a home server with the hope of hosting my own sites in the near future. I hail from a Java background so am familiar with Tomcat and MySQL and familiar with my VPS at my hosting provider that uses Linux, Apache, Tomcat and MySQL.

In trying to replicate a similar environment on my development machine, I have opted to use and configure the latest (1.81) (.exe)Xampp. On Windows 7 (unlike my hosting provider's Linux)

I believe the following services to be installed (and configured) correctly:

  • Apache (accessed in browser) via localhost:80
  • Tomcat (accessed in browser) via localhost:8080 with the welcome Tomcat page)
  • MySQL changed the root password in xampp security menu from the xampp/index.php)

Moving on I have port forwarded port 80 on my router to refer to my local ip 192.168.56.1 And am able to access both Tomcat an Apache under my local IP and their ports.

I have also configured port 80 as an inbound port through my Windows firewall.

The last step I take is to try access my services via my WAN IP, e.g. 88.89.xxx.245:80

Right (I know I am not supposed to try access my WAN locally) I try access my WAN locally I get my routers control panel when doing so. So, I turn off wireless on my Android and use the mobile internet from my phone service provider (ensuring it's not on the LAN)and try access my WAN via Android (only the Apache service) and get the infamous timeout as the response.

I have also attempted to see if both services are accessible via http://canyouseeme.org but both ports fail.

Any pointers to what I could be doing wrong here?

share|improve this question

1 Answer 1

Make sure all services that you need to access from the outside (e.g. Apache) are not listening on the loopback interface (127.0.0.1), but on 0.0.0.0 (all interfaces). You can see this using the netstat command (I don't have a Windows machine at hand to give you the exact command).

share|improve this answer
    
@Unkown It would seem that it is running on my local IP in addition to the loopback interface as going to either adress (plus :port) lands me up on xampp landing page when I use the Xampp port. I presume this is a setting issue. Do you know perhaps which configuration file I must alter and how? In the mean time I shall look online. Thank you. –  thejartender Oct 27 '12 at 15:42
    
It should be ok if it listens on your local IP besides the loopback. Could you try accessing your web server from a different machine in your LAN (e.g go to 192.168.56.1 from another machine on the same subnet, or from the router if you have shell access to it) ? If that works, maybe the port is not forwarded properly by your router. –  Unknown Oct 27 '12 at 16:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.