Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I did similar threads on this issue, I modified browser.search.defaultenginename and browser.search.defaulturl to Google, it still comes back with Yahoo. I am stuck, not sure how to change the defaults

share|improve this question
    
the easiest way to see what's left is to search for the keyword "yahoo" itself in about:config and see what keys are still left with yahoo value –  Chin Oct 27 '12 at 16:47
    
no there are 3 flags and they don't work –  Joshua Oct 27 '12 at 17:21
    
have you tried the keyword.url? –  Chin Oct 27 '12 at 17:24
    
I did, didn't work (FF on Ubuntu) –  Joshua Oct 27 '12 at 17:34
    
is there any plugin of yahoo? have you tried reset firefox? –  Chin Oct 27 '12 at 18:14
show 1 more comment

2 Answers

First of all i'm using ubuntu 12.04

open Firefox in URL bar type about:config and press enter

in search bar type keyword.URL after locating double click on it and modify it's value to

For Yahoo: http://search.yahoo.com/search?p=

For Bing: http://www.bing.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

For Google: http://www.google.com/search?&q=

DONE.

Example

changing default search engine to yahoo

enter image description here

share|improve this answer
add comment

Assuming that you don't have a Yahoo bar installed in your browser, you should be able to change the search engine by simply selecting the name from the "Search" field (next to the address bar) without going into about:config. I think you have something from Yahoo that's putting it back, or your preferences are owned by some other user id for some reason. Try resetting the permissions on your ~/.mozilla directory like:

sudo chown -R $USER ~/.mozilla; sudo chmod -R u+w ~/.mozilla
share|improve this answer
    
No its a multi-user Ubuntu system and I don't have an Yahoo toolbar. Even if I change it manually to Google, it comes back with Yahoo on re-start. –  Joshua Oct 29 '12 at 4:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.