Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Actiontec GT701D DSL Router and a Linksys EA3500 router. The Actiontec router only has one ethernet port so the Linksys router works as the AP for all computers on the network. I have a server connected to the Linksys that wants to accept connections from the internet, but nothing seems to be able to connect to it. (It can access the internet just fine). But computers within the same subnet are able to connect to it. The Actiontec set the Linksys as a DMZ and the Linksys is forwarding the appropriate ports to the server, which has a reserved/static IP via DHCP.

Actiontec - WAN IP: ISP provided, Subnet: 192.168.0.X

Linksys - WAN IP: 192.168.0.2, Subnet 192.168.1.X

Server - WAN IP: 192.168.1.103

I am pretty convinced that this is an issue with routing tables, but whenever I try creating a new entry on the Actiontec router nothing shows up on the Routing Table.. which leads me to believe my entry is wrong or there is something wrong with the firmware, probably the former. How should I configure static/dynamic routing and NAT on either the Actiontec or Linksys router so that connections from the internet make it through to the server on the linksys subnet? Port scans show 0 open ports, which I know can't be right.

share|improve this question

migrated from serverfault.com Oct 27 '12 at 17:32

This question came from our site for professional system and network administrators.

1 Answer 1

You have a misconfigured network with double-NAT. With the GT701D acting as a router, the EA3500 has no WAN connection. It is connected to the GT701D's LAN port. So it should not have a WAN IP.

You have two ways to fix this:

1) Use the EA3500 as your LAN's DHCP server. Change the GT701D to bridging mode. Connect the GT701D to the EA3500's WAN port.

2) Use the GT701D as your LAN's DHCP server. Do not connect the EA3500's WAN port to anything. Disable the DHCP server in the EA3500. Connect the EA3500's LAN port to the GT701D. Leave the GT701D in NAT/routing mode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.