Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Something happened to one of my USB drives. When I connect it my computer, Windows thinks that it's "RAW", and asks me to format it. But it should be FAT32, and chock full of files.

  • I looked in diskpart. It shows the correct size (1TB) but shows the file system as RAW.
  • I've tried chkdsk, it says CHKDSK is not available for RAW drives.
  • I've tried using Mac's Disk Utility to repair it, but the Verify and Repair buttons are grayed out.
  • I've tried GPartEd in Ubuntu. It fails to identify the filesystem.
  • I've tried using ntfsprogs/ntfs-3g in Ubuntu 12. ntfsfix gives up and says try chkdsk. chdsk (ms-sys) is unavailable in Ubuntu 12.
  • I've tried using fsck, but it doesn't do much. I think it's only for ext partitions.
  • I've tried using TestDisk. I answered Y to Write FAT boot sector, confirm ? (Y/N), and it responded: Write error: Can't write new FAT boot sector
  • I've tried using Recuva. It says Data error (cyclic redundancy check).
share|improve this question
2  
You can try a low-level data recovery tool like Recuva. But generally, it's not worth the effort and you should just requalify the drive and reformat it. Recover your data from a backup. –  David Schwartz Oct 27 '12 at 19:15
    
testdrive or testdisk? I've never heard of testdrive –  Journeyman Geek Oct 28 '12 at 2:12
    
@JourneymanGeek My typo, it's "TestDisk". Either way, it fails to work. –  mcandre Oct 28 '12 at 2:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.