Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm unable to link my Gmail account to Windows 8 Mail app when I have 2-step verification enabled on my Google account. The error message that's given is: "That email address or password didn't work." Disabling 2-step verification on my Google account fixes the problem. I guess this is really more of a bug report than a question, but I would love to hear if anybody else has a workaround that doesn't require me disabling the security on my Gmail account.

share|improve this question

4 Answers 4

up vote 18 down vote accepted

There is actually a simple way to get your GMail acount to work with Windows 8 Mail App even with 2-step verification enabled. You'll just have to use Application Specific password.

  1. Go to your Google Account settings. You must be logged in: https://www.google.com/settings/account
  2. Click on Security from the Accounts tab.
  3. In the Authorizing applications and site section click on Edit button
  4. Scroll down. At the bottom you'll see the section Application-specific passwords. Type a Name click on Generate Passwords.
  5. You'll be given a password. Use that password with Windows 8 Mail App.
share|improve this answer
    
Ooh! I like this! Great solution! –  aardvarkk Oct 27 '12 at 19:16
    
@aardvarkk it is the only one. –  Prasanth Oct 30 '12 at 18:22
4  
this solution isn't working anymore. those of you that are already connected are "grandfathered in." So, i wouldn't try removing your gmail account and re-trying the sync, won't work... –  alexfreiria Mar 15 '13 at 16:36
    
@xander This is true, but if you uncheck the contacts and and calendar data it will function. –  Highstead Jun 11 '13 at 5:04

Another possibility is that it's failing because Google recently deactivated Exchange ActiveSync for free Gmail accounts. Try un-checking the option to include contact and calendar data, which makes the Mail app use IMAP instead of EAS.

share|improve this answer
    
I appreciate you adding this. This is what worked for me. Once I unchecked the option you mentioned, it worked. Thanks. –  Tyson Phalp Mar 22 '13 at 14:49

You need to create an app password for the Mail app at gmail.com

share|improve this answer

It does work, you have to use a "Application-specific passwords" if you have one, otherwise you need to create one. You can learn more about that here.

Basically you are going to go to your security settings where you enabled 2-step authentication, and select edit, scroll down to the bottom and click the link that says "Manage application-specific passwords"

Scroll all the way to the bottom of that page and generate a new password, after giving it a name

That is the password you will use in Windows Mail.

share|improve this answer

protected by Community Mar 31 '13 at 5:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.