Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have got a problem with either my router or my ISP provider. Please let me know if you can work out what could be wrong.

My observation:

  • downloading large files (over .5 GB ) works well, download speed is quite good
  • when I browse websites, some websites are really slow and some don't load 100% especially images. When I refresh, sometimes they reload fine, but most of the time the page reloads with no images again
  • occasionally I get an error saying: DNS lookup failed
  • also I noticed that when I turn on another pc in the same network, the internet goes down on both, and I have to run the troubleshoot-repair thing (windows 7)

I phoned up my ISP (BT Business broadband), they checked the logs and said that they couldn't see anything wrong , no disconnections or anything else.

If it is the problem with the router, are there any tests I could run to find out where exactly is the problem?

If you have any questions please please ask, I will try to help you help me.

share|improve this question

migrated from serverfault.com Oct 27 '12 at 19:08

This question came from our site for professional system and network administrators.

    
try a new adsl router. The one bt supply are not fit for domestic use never mind business. –  user37899 Nov 16 '11 at 22:36
    
Who/what are you using for DNS? –  xeon Nov 17 '11 at 0:32
add comment

1 Answer 1

also I noticed that when I turn on another pc in the same network, the internet goes down on both, and I have to run the troubleshoot-repair thing (windows 7)

This could be that both computers are trying to call for the same IP, maybe it's set up that way for some reason, but you should let the router use DHCP to assign IPs automatically. It's probably disabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.