Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7, and Windows 8 on my laptop. I have Windows 7 set as my default, and it asks me each time if I want to boot with 7 or 8. When I boot with Windows 8, then restart my computer, it opens up to the Windows 8 boot screen and sets Windows 8 as my default. How can I stop it from changing my default OS? It's a hassle to change my default each time I want to use Windows 8.

Note: This only happens sometimes. It usually doesn't change my default OS when I restart, but it sometimes changes when I completely shut my laptop off.

share|improve this question
3  
I wonder if that is by design, you know defaulting to the last OS that you used.... Let me see... –  TheX Oct 27 '12 at 19:13
1  
I can't simulate this. Changed default to Win 7, it's stuck to that. –  Sathya Oct 27 '12 at 19:14
    
Same... Not sure.... –  TheX Oct 27 '12 at 19:17
    
I never have that problem –  Chin Oct 27 '12 at 19:35
    
I wonder if it's a driver or something then... –  leaf68 Oct 27 '12 at 19:38
show 2 more comments

3 Answers

I've noticed similar behavior on occasions. The reason could be Windows 8's Hibernation settings. Check your Power Options.

enter image description here

If you have enabled Hibernation, then when the system hibernates after the set period and later you power on your system, it would automatically resume on Windows 8. This would have higher priority over the boot sequence, as you have never actually quit Windows 8. It is simply resuming your session.

Also the new Windows 8 Start/Restart/Hibernate/Resume UI just has the loading logo and no messages indicating the ongoing operation. So its hard to distinguish between restart and resume.

enter image description here

share|improve this answer
    
I am totally agree with you @AbhishekGirish. I also have same problem and I suspect same behavior and on disabling the hibernate option this is never happend again :) –  Wolvorin Oct 29 '12 at 5:11
add comment

Try using bcdedit.

Warning: Be sure you type the commands correctly or your machine may become unbootable.

  1. Open a command prompt as administrator.
  2. Type bcdedit /export C:\bcd_old.bak or something similar to backup the boot configuration data.
  3. Type bcdedit /v to display the boot configuration data.
  4. Copy the identifier for the Windows 7 boot entry (it looks something like
    {1e940af5-47c7-11e1-9d16-ceef4a66119e}).
  5. Type bcdedit /default {identifier of Windows 7 boot entry}
  6. Do this on both Windows 7 and Windows 8.

Now the default should be Windows 7 regardless of which OS was used most recently.

share|improve this answer
add comment

I think you have to disable Fast Startup for this to be fixed

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.