Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install a dual boot Windows 7 Home Premium and Windows 8 Pro on an XPS 8500 special edition. I created a new primary partition from my C drive, inserted the Windows 8 install disk, and rebooted my computer from the DVD.

I select custom install and the dialog box saying "Where do you want to install windows at?" pops up but none of my drives are listed. I don't understand why none of my drives are showing up on this menu. Not even the original drive. When I select to load a driver and click on the partition I created it tells me "No signed device drivers were found. Make sure the installation media contains the correct drivers, and then click OK."


Running the setup program from within the installed Windows instead of booting from DVD was able to locate my new partition and start install. It completes the first step of "Copying windows files" just fine but then on the next step "Getting files ready for installation" my computer restarts and attempts to load Windows 8 but keeps telling me my PC needs to restart. This keeps going on in an infinite boot loop. Please help, this has been a nightmare!

share|improve this question
    
I was not aware you could create a new partition while you were already booted up. What tool did you use for this? –  Caleb Jares Oct 28 '12 at 1:43
    
@cable729: There are any number of 3rd party utils, and of course there's the inbuilt diskmgmt.msc as well. Jesse: Does your hard disk require special drivers? Have you ever reinstalled Windows on your machine? –  Karan Oct 28 '12 at 2:33
    
Yes I tried using both disk management and easeus partitioner. No luck. I resolved this issue by running the setup from the source folder on the install disk instead of booting from DVD and I was able to start the install on the correct partition but my computer is getting hung up and keeps restarting while install. It is getting stuck in an infinite boot loop. Any suggestions? –  Jesse Oct 28 '12 at 4:15
    
How can I find out if I need special drivers? I may because I also have a 32GB ssd cache –  Jesse Oct 28 '12 at 4:24
    
If you're installing a second OS to your 32GB ssd, you need to make sure you have 20GB available. I believe that is the amount required for Windows 8 –  Caleb Jares Oct 28 '12 at 5:17

1 Answer 1

The solution to this problem was tracked through comments to the question itself but in case somebody stumbles upon something similar this would be the way of fixing it.

The problem with the setup program not being able to see drives or partitions may be related to it not having access to a suitable AHCI or RAID driver. Windows 8 supports some configurations but some others require a driver.

  1. Access a Windows 7 (or Vista, or XP) system running in the machine you wish to install, through the device manager find the SATA controler (AHCI or RAID may be in its name too). For example in this particular case it was "Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller".

  2. Download the drivers for your SATA or RAID controller, there'll need to be an INF file and some catalog and system files along. Copy them to a USB stick and reboot the computer booting into Windows 8 installation.

  3. When you reach the stage where you have to select where you'd like to install it plug in the USB stick (preferably in a USB 2.0 port, but I believe Windows 8 has native support for USB 3.0 too) and load the driver from the folder containing it.

  4. After that Windows should be able to access the drives and partitions and the installation should proceed as usual.

When the driver to access the storage system is not present by default in the installation DVD, installing from the Windows already running in the system is not recommended and may fail. The reason is that while that windows does have access to the drive, the new one wont and after rebooting it may lead to infinite reboot cycles.

share|improve this answer
    
The comments about needing to load the AHCI or RAID drivers can also apply pretty mucht to any version of Windows. –  Ramhound Feb 7 '13 at 15:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.