Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've found that on a very fast new machine CPU usage runs between 0-8% normally, but then with wmplayer on it hovers between 8-18%. The problem is particularly to my new machine with Windows 7, and doesn't occur on my old Vista machine.

I believe it's possibly because every time I open wmplayer it tries to load up every media file on my computer into the startup screen. Assuming I want to keep using wmplayer (and since I've got a lot of playlists set up there, I do), how can I fix this problem?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Try to ending the process, this should end all spikes. Try using Vlc Media Player.

Alternatively, set wmp to not index all media files. To do this follow the information below.

Open Media Player > Click Organize > Select Options Under the Library tab, Uncheck Retrieve additional information from the internet Close Media Player and reopen to see of the process is any faster.

The real way is go into Media Player.  From the menu -> File -> Manage libraries -> select each library (music, video, pictures, recorded tv [if you have]) and check the paths that it is managing and make sure it is not too close to the root of the C: drive.  For example, it should be something like c:\users\Jim\Music and c:\users\Public\Music BUT NOT c:\users as they will cause the whole directory tree to be re-indexed over and over (when you surf the web or change any files in your profile). If you have multiple users who login to the computer, you may need to repeat the process for each user if all users have added managed foldTers which are actively changing on a regular basis.

See this site for the original post.

share|improve this answer
    
Thanks for the advice. I have a couple of questions. 1. why does it need to reindex every time I open the program? On my Vista machine it does not do this, and I don't have these CPU usage problems even though the machine is much older. 2. How can I set wmplayer to not index all media files? –  user1205901 Oct 28 '12 at 3:41
1  
I updated my answer. –  wizlog Oct 28 '12 at 3:51
    
Thanks. Unchecking Retrieve additional information from the internet fixed the problem for me. None of the managed paths were close to c:\users, so I didn't change anything there. –  user1205901 Oct 28 '12 at 4:09

Win7/64

I had a problem with WMV files using 100% of a core, to fix it I turned off Options/Performance "Turn on Direct-X video Acceleration for WMV files".

share|improve this answer

Here is the definitive answer to how to stop Windows Media Player from using up all of the resources of the central processing unit. It is a really simple solution and I am so surprised that nobody has ever thought of it before I did.

Windows Media Player uses up a ton of resources to build up and keep up-to-date its in-application library, which houses references to all the compatible media that it can find in the storage of the computer. Therefore, this automated task could take very little time or a lot of time, depending on what you have stored.

The media library probably has its legitimate uses, especially for media enthusiasts, but it is not for everybody and it is especially not for everybody at all times. Ordinarily, I would be inclined to let Windows Media Player build up its media library, but in this latest incident, I was tweaking two other applications that also use music files (VirtuaGirl and Serene Screen Marine Aquarium Time). In this vein, I had intended using Windows Media Player as a control mechanism and I did not have the time to deal with the seemingly mandatory development of the Windows Media Player library and the high CPU usage that it engenders. Furthermore, reading the multitude of posts on the Internet on this subject yielded me absolutely nothing other than wasting my time with realizing that if I want something done right, I would have to do it myself.

So this is what I have done, without affecting other auxiliary and inter-related and inter-dependent Windows operations that other users would have you believe is necessary. I taskkill-ed the Windows Media Player, then renamed %LOCALAPPDATA%\Microsoft\Media Player\CurrentDatabase_372.wmdb to %LOCALAPPDATA%\Microsoft\Media Player\CurrentDatabase_372.OLD.wmdb. The file CurrentDatabase_372.wmdb is the database file that Windows Media Player uses to update its library. It is not sufficient to just taskkill it or even to delete it because Windows Media Player will simply restart it or recreate it. Instead, you have to either disable or delete the file and fool Windows Media Player into believing that it is still there. In my case, I chose to rename the file with the .OLD.wmdb extension and then, in order to avoid Windows Media Player from recreating the file, I simply created an empty dummy file (like an empty *.txt file) and attributed the name of the original file that I disabled. And, POOF, just like that, the problem got taken care of.

Please remember: I, Neal Bangia, figured this out!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.