Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am going nuts reinstalling Windows 7 on one of those Acer aspire all-in-one... The original OS (Windows Professional x64) was not starting, after the initial screen the BIOS was prompted. So

  • Step 1: I tried to access the system partition and reinstall everything but could not get to that point

  • Step 2: I set the BIOS to  native IDE and I tried to insert my original copy of Windows Professional and do a clean installation, but it does not allow me to format/create another partition for the installation mask

  • Step 3: I tried to install Ubuntu and I cleaned the whole hard drive, I was getting an error at some point during installation so I decided to get back to Windows

  • Step 4: Windows 7 again, at the disk screen of the Windows installation I opened the prompt and played around with DISKPART...

    • I listed the disk and the HD was disk 0.
    • I selected disk 0.
    • I CLEANed disk 0 successfully.
    • I tried to create a CREATE PARTITION PRIMARY but gave an error about the cache being corrupt and the disk not being up-to-date (after I tried to create a partition in disk 0 it disappeared when I try LIST DISK and I have to restart before it can list DISK 0 again. RESCAN did not work).
    • Tried CLEAN ALL (2 hours) and succeeded.
    • Tried again to create a primary partition and failed, same errors
    • Tried to install my old copy of Windows XP Pro and it seems to work, it creates a partition, formats (only "quick" worked, slow mode was at 0% and after 1 hour so I stopped), it starts installing and at around 90% installation it says it could not copy a file and it stops.
    • Back on Windows 7 again, it says that the hard drive has 490+GB unpartitioned but won't create a partition and format.
    • I tried again with DISKPART as I thought I messed up the MBR when I installed Ubuntu, so I did all of these instructions.

The errors were:

  • On bootsect:

    the system partiton was not found, Data error cyclic redundancy check

  • on bootrec /FixMbr:

    A device attached to the system is not functioning

But it did not work, and I still can not partiton/format/install on a blank HD. I tried some bootable clean disk tool and started an infinite loop on the same errors.

The BIOS setting are: SATA: native IDE. If I set AHCL (or something like that) it does not load the HD and the DVD. Quick start/quiet start: disabled.

Are there any other options or tools I can try before I change the HD (that is my last option)?

share|improve this question
    
Why not use the gui interface of Windows setup to delete and create partitions? –  Moab Oct 28 '12 at 4:30
1  
Try using GParted from a bootable USB/CD. However CRC error doesn't fill me with confidence that your drive is ok. Be sure to test thoroughly with the drive manufacturer's utility before install the OS and saving your data to it. –  Karan Oct 28 '12 at 4:34
    
the user interface wont create/ format/ partition the hard drive –  fra pet Oct 28 '12 at 4:36
add comment

1 Answer

Sir, the erro message (step 4-4) was clear as clean water. The disk cache (RAM inside the HDD) is corrupt. Either you find a way to completely disable it (and have a disks that is as slow as a tortoise), or you get a replacement disk.

odds: -> encountering an error in linux: bail out -> encountering an error in windows: retry, retry, retry, ask a question. Weird behaviour...

share|improve this answer
    
If the error message was that clear, I assume someone by now should have gotten it. Can you try to explain or expand a little more your answer, leaving personal considerations aside (your last paragraph). –  Doktoro Reichard Sep 21 '13 at 21:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.