Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Arch Linux + Windows 8 on my laptop. In previous versions of Windows, there is a DWORD in the registry (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal) that switches between localtime and UTC, but this doesn't seem to be working in Windows 8 anymore.

I am now getting UTC time in Windows since it thinks BIOS gives it localtime which is actually UTC time, and after reboot into Arch Linux, the clock becomes localtime-0400, because Arch thinks BIOS is having the correct UTC time.

I do not want to let Arch Linux use localtime. Under this prerequisite, is there any possible solution?

share|improve this question
The RealTimeIsUniversal key worked fine for me, dual booting Arch Linux also. – numbers1311407 Nov 22 '12 at 17:23

6 Answers 6

up vote 2 down vote accepted

RealTimeIsUniversal is really buggy and not an officially recommended solution (maybe that's why they disabled it in Win8?) See IBM PC Real Time Clock should run in UT and a response from Raymond Chen here: Why does Windows keep your BIOS clock on local time?. As of date I don't think there's a proper solution for this.

share|improve this answer
buggy? never had any problems with it, and forcing windows to use a UTC system clock really is the only sane solution. and the key is not disabled in win8. real solution is to set the registry key, turn off windows’ time sync, and let linux handle the syncing if you boot there often enough. – flying sheep Jan 8 '14 at 19:19
@flyingsheep Over the years a few hotfixes have been released, see Current support status in Windows on – Stijn May 12 '14 at 21:16

The default Windows Time service will always write local time to the hardware clock on shutdown, regardless of what the registry says about the real time being in UTC. Outside of this caveat, Windows will treat the hardware time clock correctly, if the registry is set correctly. Try this:

  1. If the time is messed up from trying to get Windows to use UTC, boot into Windows, and set the time as it would be normally (correct timezone, no regedit, Windows Time service enabled, recently synced, etc)
  2. Do the regedit you mentioned already
  3. Sync the time w32tm /config /update
  4. Disable Windows Time service sc config w32time start= disabled
  5. Install a 3rd party NTP client
  6. Verify that it works with a reboot
share|improve this answer
Just set this up myself after having Windows set the clock on each shutdown. Found the following NTP software for Windows which is very easy to setup and configure. – Dracs Sep 5 '13 at 5:19
That software seems to be a repackaging of the official NTP distribution, with some extras. Anyway, I used it and also found it to work. – David Z Jan 29 at 5:21

RealTimeIsUniversal registry key still works in Windows 8 and 8.1! Just tested it by myself. The instructions to use this method are explained lot of times everywhere, for example in this answer.

share|improve this answer

@jiehanzheng yes, if you use NTP in Windows, it will mess up the clock. Sounds like the best workaround is to run NTP in whatever flavor of *NIX you're dual booting, disable NTP in Windows, and offset using whatever time zone you need to. Then you just have to adjust daylight savings time manually with a time zone shift in Windows, but eh..

share|improve this answer

RealTimeIsUniversal works for me. To get it to work, after applying the registry entry, shutdown Windows (not sleep or hibernate). Boot machine & enter BIOS before booting into Windows, change the time in BIOS, save, then continue booting into Windows. Alternatively, after shutting down Windows, boot into Linux & let time sync do its job. If time is updated from within Windows, Windows will somehow update an incorrect time to the system after a reboot.

  • bozoid, kh
share|improve this answer
Could you link to sources that explain RealTimeIsUniversal? I didn't know what it was until you mentioned it, and from a number of results, it looks like it comes with its own set of potentially negative side-effects. – killermist Feb 6 at 5:44

You could just set your time-zone four hours off.

enter image description here

share|improve this answer
Smart workaround... but the hardware and system clock will be messed up again when I use NTP (Internet Time), right? – jiehanzheng Oct 28 '12 at 17:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.