Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
How do I set up SSH so I don’t have to type my password?

I am trying to set up Opennebula. I want to set up my local host so that I can log into my remote host without having to use the password.

I have followed the instructions in the "Secure Shell Access" section in the installation instructions. I can not log into my remote host from my local host, but I can log into my local host from my remote host.

Not sure what's going on.

Any help would be appreciated.


share|improve this question

marked as duplicate by akira, Nifle, Hennes, Randolph West, Sirex Oct 28 '12 at 19:30

This question was marked as an exact duplicate of an existing question.

Sounds to me like you reversed the SSH key setup. You have to create the key pair on the local host and put the public key into the authorized_keys file on the remote host.

Use ssh -v user@remote_host to see what happens on the client side. Also check the sshd log (location will vary depending on what distribution you're using, on Debian/Ubuntu it's /var/log/auth.log). You may need to increase the log level from INFO to DEBUG on the server and run service ssh reload.

share|improve this answer
As described in the installation instructions I have created the key pair in the host and copied the whole folder to the host. But I have also tired copying just the public key to the authorized_keys file on the remote host. Non of the methods worked. – user477519 Oct 28 '12 at 12:21
@user477519 See updated answer. Also you may want to describe how exactly the methods "don't work". Do you get any error messages? Which command do you run on which host, and what output do they produce? – Ansgar Wiechers Oct 28 '12 at 12:35
I meant by dont work was, it still asks for a password. I have found the solution for this issue. Please refer to the new answer. Really appreciate your effort. Thanks – user477519 Oct 28 '12 at 12:41
Append the output of ssh -v user@host to you question. – ott-- Oct 28 '12 at 13:00
The solution was that the home folder of the user that I try to log into using SSH did not have permissions to read from or to write to its home directory. So after changing the permissions, it worked! I can not post this answer as a solution as it is already marked as closed due to duplication, although other posts did not help me to solve this issue. – user477519 Nov 12 '12 at 14:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.