Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed XAMPP 1.8.1. on my Windows 8 64bit machine. I'm now facing a problem with ports. This is what I got from XAMPP Control Panel:

11:52:43 AM [Apache] Problem detected!
11:52:43 AM [Apache] Port 80 in use by "c:\windows\syswow64\wwahost.exe"!
11:52:43 AM [Apache] Apache WILL NOT start without the configured ports free!
11:52:43 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:52:43 AM [Apache] or reconfigure Apache to listen on a different port
11:52:43 AM [Apache] Problem detected!
11:52:43 AM [Apache] Port 443 in use by "c:\windows\syswow64\wwahost.exe"!
11:52:43 AM [Apache] Apache WILL NOT start without the configured ports free!
11:52:43 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:52:43 AM [Apache] or reconfigure Apache to listen on a different port

WWAHost.exe is needed for Metro Apps (wwahost.exe) so I don't know which is safer, change WWAHost.exe's ports or change Apache's ports? How would I accomplish this?

EDIT 2013/01/16: I've reinstalled W8 and Apache server. Apache is now using port 80. Before installing Apache server I've removed almost all Metro/Modern UI Apps.

share|improve this question
    
Interesting problem. I would imagine WWAHost is a service that can be turned off via Win + R -> services.msc if there is no need for it. Changing the port of Apache can be done in C:\Program Files (x86)\Apache Software Foundation\Apache2.2\conf\httpd.conf: Change Listen 80 to Listen 8080 or anything else. –  Henning Klevjer Oct 28 '12 at 11:18
1  
Thank you! Well I think that there is need for it... –  Peter O. Oct 28 '12 at 11:25
    
You should wait for someone more Win8-savvy to come around with a registry hack or something to circumvent the port hogging. –  Henning Klevjer Oct 28 '12 at 11:26
    
Using port 8080 works well (for now :)). But I have to type localhost:8080, not only localhost - but I can make a bookmark :) –  Peter O. Oct 28 '12 at 11:28
1  
Thats a pretty interesting 'bug' - considering windows 8 has IIS as an option, and this has taken up both the HTTP and HTTPs ports. –  Journeyman Geek Oct 28 '12 at 11:40
add comment

5 Answers

up vote 2 down vote accepted

You're better off changing apache's port to something like 8080 in case wwahost.exe does have a real function.

share|improve this answer
    
Thanks! I have used this video youtube.com/watch?v=f1qS5oiK-i0 . But I wonder if it's possible to use localhost, not localhost:8080. PS: Sorry I can't increase answer value because of my low reputation. –  Peter O. Oct 28 '12 at 11:23
1  
just connecting to localhost will require the port number to be 80, as this is the standard HTTP port, so this is not possible. –  Henning Klevjer Oct 28 '12 at 11:27
add comment

Do you by any chance have the new Windows 8 Skype installed? If so, it unfortunately uses Port 80, you should close Skype from the background, and run it again. It should work.

share|improve this answer
    
Yes, Skype is installed on my W8. But switching port is the best solution. –  Peter O. Oct 29 '12 at 18:26
add comment

Microsoft's wwahost.exe is the host process for (means "runs") all the internet explorer based apps that are built around JavaScript and css.

share|improve this answer
add comment

I did the 8.1 update for Windows and Skype App now can no longer be removed. When I tried to activate the WampServer came across the conflict TCP port 80 that kept him from starting Apache.

After searching on Google without success, open the Windows Firewall with Advanced Security, and discovered the following input rule entry:

@{microsoft.windowscommunicationsapps_17.0.1119.516_x64__8wekyb3d8bbwe?ms-resource://microsoft.windowscommunicationsapps/resources/communicationsPackageName}

I just deactivated this rule. After that I managed to start Apache usually to TCP port 80.

I did not notice any change in other Windows features. 'll Still follow it carefully but solved my problem!!

share|improve this answer
add comment

As Mohamed Mansour mentioned, this can be caused by using Skype. The new Windows 8 metro version is run under the WWAHost.exe process, as are other metro apps.

Simply close Skype, start Apache, and then you can open Skype again. To fully close a Windows 8 metro app:

  • Hover over the top edge of the app until the cursor shows as a hand
  • Drag app to the bottom of the screen and hold
  • Wait for the app to flip over, then release the mouse

Skype will silently use a different port if it's already taken by Apache.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.