Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am getting following error when installing visual studio express edition on windows 8

You need to restart your computer to continue the installation

Screenshot for illustration, it's the same screen for me, but it says Express instead of Ultimate:
enter image description here

I have restarted computer many times,but same problem comes each time.

share|improve this question
    
Have you tried to run the installer as admin? –  page4096 Oct 28 '12 at 11:36
    
What comes after you restart? –  pratnala Oct 28 '12 at 11:49
    
Did you download ISO or Web-Installer? Try ISO if Web-installer was downloaded. –  Maximus Oct 28 '12 at 12:00
    
see my answer ,I got the screenshot from the link specified there.I forgot to take screenshot of my own version of visual studio.This is to help others... –  vishesh Oct 28 '12 at 12:57
    
What are the contents of the log file that is mentioned in the screenshot? –  Oliver Salzburg Oct 28 '12 at 13:37

2 Answers 2

up vote 1 down vote accepted

finally I was able to solve my problem by following these steps :

  1. first Open registry (as administrator) and browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
  2. See if there is a string value "PendingFileRenameOperations" and check the value
  3. if there is one, Rename the string value "PendingFileRenameOperations" to something similar to "PendingFileRenameOperationsrename"
  4. reinstall VS2012 RC
  5. after install VS2012 RC successfully, rename back the string value

I found these from here :

http://social.msdn.microsoft.com/Forums/nl-NL/vssetup/thread/942fd4f7-9085-4cbf-bb98-a58706dbb693

HTH

share|improve this answer

Make sure that you've downloaded the right Visual Studio 2012 for Windows 8. Also if something strucks please click Uninstall and then click Repair. I've got the same problem and I've been working with it since that fixed my error.

share|improve this answer
1  
I have downloaded the right version,but it never installs due to error.how do i uninstall it then.. –  vishesh Oct 28 '12 at 12:33
    
Go to Control Panel->Programs and Features and then double click on Miscrosoft Visual Studio 12 then Click OK and then reinstall it. –  GTS Oct 28 '12 at 13:02
    
It was not even installed in the first place.anyways I have solved my problem and given the answer here.Thanks for any help –  vishesh Oct 28 '12 at 13:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.