Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an ASUS G75VW laptop with a Synaptic touchpad (/trackpad). When I move my finger from one edge towards the middle (the swipe), Windows 8 will bring up different stuff.

This is a problem because the area where I can actually move the mouse with my finger is too small (or, I mostly use the top left of the touchpad). So I often end up doing a swipe and bringing up some menu, or to do the swipe so slow that no menu is appearing but the mouse pointer is also not moving when I move my finger. Quite annoying.

When swiping from left edge it earlier swapped apps like crazy. I disabled that, so now it only brings up the same menu as pressing win+tab (or some times the charms bar, I never know which). I could change that by:

Win+I → Change PC settings → General → When I swipe from the left edge, switch directly to my most recent app.

I've tried Mouse settings in Control Panel, driver settings for my touchpad and searching for swipe and gestures on my computer (which was what led me to the setting above) with no luck.

How can I disable the swipe gestures, or change what they do?

share|improve this question
    
To modify the size of the swipe area, see this Q: superuser.com/a/502030/127618 –  Matsemann Feb 1 '13 at 9:17
add comment

10 Answers

up vote 24 down vote accepted

Doing this involves editing the registry, it is recommended to do a manual system restore point before doing this.

You will need to make a file called gestures.reg, open notepad and paste the following:

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Right Edge Pull]
"ActionType"=dword:00000000
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Left Edge Pull]
"ActionType"=dword:00000000
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Right Edge Pull Extended Zone]
"ActionType"=dword:00000000
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Top Edge Pull]
"ActionType"=dword:00000000

Save this file somewhere, with the .reg extension.

Now run it, some warning boxes may come up, you will need to press Yes when they do, after the operation has finished, reboot your PC and they should now be disabled.


If you want to re-enable these gestures, then you will need to do the same but use the following text when saving the file:

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Right Edge Pull]
"ActionType"=dword:00000002
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Left Edge Pull]
"ActionType"=dword:00000002
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Right Edge Pull Extended Zone]
"ActionType"=dword:00000002
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2\Top Edge Pull]
"ActionType"=dword:00000002
share|improve this answer
    
Thanks, this worked as expected. –  Matsemann Oct 29 '12 at 10:55
1  
Works great. I wanted to change only the right edge gesture, so I just changed the setting in regedit. –  Guffa Dec 24 '12 at 15:35
4  
Works great, although the key for me is called TouchPadPS2_1 instead of TouchPadPS2 (there is no TouchPadPS2 key). So it might be worth inspecting or doing manually with regedit if the .reg file doesn't work for you. –  hheimbuerger Apr 2 '13 at 8:01
    
This has recently stopped working for me after updating the synaptics driver to version 17 (win 8.1) –  Eamon Nerbonne Nov 8 '13 at 21:52
1  
Finally got this working on Fujitsu Celcius H series using TouchPadPS2_3 in stead of TouchPadPS2. (on windows 8.1) –  steenhulthin Jan 28 at 20:51
add comment

As @hheimbuerger mentioned above, replacing "TouchPadPS2" with "TouchPadPS2_1" for Synaptics ClickPad V8.1 works. The modified gestures.reg script is this:

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2_1\Right Edge Pull]
"ActionType"=dword:00000000
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2_1\Left Edge Pull]
"ActionType"=dword:00000000
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2_1\Right Edge Pull Extended Zone]
"ActionType"=dword:00000000
[HKEY_CURRENT_USER\Software\Synaptics\SynTPEnh\ZoneConfig\TouchPadPS2_1\Top Edge Pull]
"ActionType"=dword:00000000

After running, reboot is necessary.

share|improve this answer
add comment

The instructions for Toshiba Satellite laptops (because Regedit didn't work):

  1. Press Win+Q
  2. Type mouse
  3. Underneath, select "Settings"
  4. Select "Mouse"
  5. Go to the "Device Settings" tab (on the far right)
  6. Select "Settings..."
  7. Untick the "Enable Edge Swipes" checkbox
share|improve this answer
add comment

On my gateway, go to the charms bar, type in mouse and select the first choice MOUSE that comes up. Select the Edge Actions and uncheck. simple as that.

share|improve this answer
add comment

For my Dell, I went to Control Panel > Hardware and Sound > Devices and Printers. Right click on the laptop picture and select Mouse Settings. Click on Dell Touchpad, and in that screen select the link that says "Click to change DellTouchpad settings". Go to Gestures.

Swipe options are listed on this screen.

share|improve this answer
1  
+1. You can imagine that under the hood this just changes the values in the registry to what @DanielB says, but doing it this way is a whole lot easier than using regedit. –  PeteH Feb 11 '13 at 16:27
add comment

The Synaptics TouchPad setting on an HP laptop allows you to customise or turn off a lot of irritating stuff as well as the swiping thing and is well worth checking out.

share|improve this answer
add comment

On my Acer Aspire with windows 8, I right clicked the bottom left corner to reach the control panel. From there I went to mouse options, then to ELAN, and from there to options. This gave me the option to disable edge swiping, which seems to have worked quite well.

share|improve this answer
add comment

I have an HP Sleekbook and was able to turn off the gestures by following these steps:

  1. Go to start screen
  2. Select the settings block under the search bar on the right side.
  3. In the search bar begin typing enable edge swipes or edge swipes.
  4. Click on the 1st option that comes up (it looks like a gear) [This is under PC settings]
  5. Where it says enable app gestures click OFF
share|improve this answer
    
Seems it only works on HPs, but thanks anyway. –  Matsemann Jan 1 '13 at 14:52
add comment

I have an HP that also has a Synaptics TouchPad and I just searched (in the main Windows 8 search thing) "touchpad" and it brought up a few different results under "Settings", one of which was the Synaptics TouchPad that I have, so I clicked on it and it opened a window with settings for my touchpad. One of the settings says "Enable Edge Swipes" and I just unchecked it and now it's good.

share|improve this answer
    
I don't have that option, but thanks anyway. Will probably help others. :) –  Matsemann Nov 6 '12 at 22:33
add comment

Daniel B's answer worked great.

However, after experimenting with drivers I found a Synaptics driver from ASUS that comes with something they call ASUS Smart Gesture. There, under the Edge Gesture tab one can disable the different swipe gestures. Easier and safer than messing with the registry.

However this only works for ASUS computers, while Daniel B's answer should work for most Synaptic touchpads.

share|improve this answer
add comment

protected by Community Feb 24 '13 at 16:22

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.