Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My PC doesn't go past the motherboard manufacturer logo. I tried to reset the BIOS. I have two RAM slots and 1GB RAM. I tried reinserting the RAM in other slots.

enter image description here

I think the red light shows that the hard drive is working fine.

enter image description here

share|improve this question
    
Does it get stuck up therE? –  pratnala Oct 28 '12 at 18:04
    
Yes,it doesnt go beyond it.!! –  Manoj Kumar Oct 28 '12 at 18:05
    
How old is your PC? –  pratnala Oct 28 '12 at 18:06
    
May be 5 years..!! –  Manoj Kumar Oct 28 '12 at 18:08
    
If the red light is on solid, I'd check all my connections inside the box (reseat the RAM, the power supply, the hard drive connections, etc.). Most likely though, at this age, something on the power supply or motherboard is broken. Difficult to test on such an old machine, too. –  user3463 Oct 28 '12 at 18:32

1 Answer 1

Try cleaning up the insides of the CPU (specifically the RAM, processor etc) with a vacuum cleaner. This worked for a friend of mine who had the same problem.

share|improve this answer
    
Yes,i tried doing it..but did'nt use a vacuum cleaner –  Manoj Kumar Oct 28 '12 at 18:13
1  
A vacuum cleaner is an exceptionally bad idea. It's a static nightmare. You should use a gas duster (compressed air in a can), available from most computer and electronics stores. Either way, I think the computer is probably dead. My vote is motherboard issue. –  user3463 Oct 28 '12 at 18:30
    
Thanks Randolph...i hope its not dead , i use it as a secondary pc ,when i have to download Gigs of data.. –  Manoj Kumar Oct 28 '12 at 19:04
    
So I get a downvote for saying vacuum cleaner? –  pratnala Oct 29 '12 at 2:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.