Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

could someone help me to find a solution for this problem,

when i start running synaptic package manager it gives me the following error:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct
 the problem. 
E: _cache->open() failed, please report.

command sudo dpkg --configure -a is tested on terminal as well. it gives following output:

root@kapia-laptop:/home/kapia# sudo dpkg --configure -a
dpkg: status database area is locked by another process
share|improve this question

migrated from stackoverflow.com Oct 1 '09 at 10:45

This question came from our site for professional and enthusiast programmers.

2  
Just reboot, all open dpkg processes will be closed... :) Then open synaptic again –  Aaaaaaaaaha ERLEBNIS Oct 1 '09 at 11:55
add comment

3 Answers 3

that means you have already an process of dpkg running, either as synaptic, update manager or apt-get/aptitude

as a last resort, if nothing works you can try deleting the lockfile /var/cache/apt/lock, but be careful, this can potentially corrupt your package database

share|improve this answer
1  
or there could be a stale lockfile? –  Kimvais Oct 1 '09 at 10:26
    
it's my experience this is the correct general case -- i've left aptitude running in another terminal and forgotten about it. if ps doesn't show any other dpkg/synaptic/aptitude processes running on the system, assuming the lockfile to be stale may be reasonable -- but i'd try rebooting before manually removing the lockfile. just in case. –  quack quixote Dec 23 '09 at 8:18
add comment

If it's an option, I'd just reboot. Let Linux do it's thing and close the programs properly for you. Either reboot through the graphical interface, or open terminal and run sudo reboot or sudo shutdown -r now. Upon rebooting, run sudo dpkg --configure -a. If you are still getting errors regarding dpkg being locked, follow knittl's answer.

share|improve this answer
add comment

When you running sudo dpkg --configure -a be sure, you have closed synaptic package manager, autoupdate dialog and all other software related to packages. Only one instance at time can work with packages database.

share|improve this answer
2  
No it shouldn't. linux != server (at least not all the time). –  tj111 Oct 30 '09 at 19:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.