Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a brand new wireless router because all my devices are N or N+ so I figured if I had a router that could support it, I could get some better LAN speeds.

I installed my router, set its WiFi to N only, and made sure it was using WPA2 + AES to maximize the speeds I would get on my devices.

When I first connected my laptop I was getting 150 which is not fantastic, but still alight. I rebooted my router and no no matter what I do all my devices are stuck at 65. I tried a hard reset but still I am stuck on 65, and its starting to make me mad.

I have reset the WiFi about 100 times now, and manually changed the channel it works on, and some times it would get back to 150, but then would drop down to 65 after a few seconds.

What am I doing wrong here exactly? What do I need to do to get everything to work properly at 150 or preferably 300+. The router I bought was a DLINK DIR-855, and all my devices are within 20 feet from the router, which is in the same room.

share|improve this question
    
How do you measure that speed of 65Mbps? –  user3463 Oct 28 '12 at 21:07
    
On all my devices if I look at the network adapter settings it shows it. And when I transfer files I cap out at around 5 Mb/s –  Landin Oct 28 '12 at 21:15
    
Fair enough. Have you tried changing the channel (or setting it, since many devices like auto-channel hopping?) I usually recommend 6 or 11. –  user3463 Oct 28 '12 at 21:20
    
I did try that, and it worked for a few seconds but then it changed back to 65. –  Landin Oct 28 '12 at 23:47

1 Answer 1

Try disconnecting all wireless devices and then connecting them one at a time, checking that speed readout after each new device is connected.

I'm not 100% sure about the N standard, but with some of the older standards, one device could slow down the rates for all devices (ie. when a B device connects to a G network, the G network slows to B speeds). Perhaps something similar is happening here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.