Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am connecting my server to my HDTV so that I can conveniently display it there. My VIZIO HDTV cuts off all 4 edges. I already realize it is not optimal to be running a GUI on a server; this server will not have much external traffic so I prefer it for convenience.

I have already spent countless hours searching for a fix, but all I could find required an ATI or NVIDIA graphics card, or didn’t work. In Windows, the Intel driver has a setting for underscan, though it seems only to be available by a glitch.

Here’s my specs:

  • Ubuntu Linux (Quantal 12.10) (Likely to switch to Arch)
  • This is a home server computer, with KDE for managing(for now, at least)
  • Graphics: Intel HD Graphics 4000 from Ivy Bridge
  • Motherboard: ASRock Z77 Extreme4
  • CPU: Intel Core i5-3450

My monitors:

  1. Dell LCD monitor
  2. Vizio VX37L_HDTV10A 37" on HDMI input

I have tried all of the following from both HDMI⇨HDMI and DVI⇨HDMI cables connected to the ports on my motherboard:

  1. Setting properties in xrandr
  2. Making sure drivers are all up to date
  3. Trying several different modes

The TV was “cheap”; max resolution 1080i. I am able to get a 1920x1080 modeline, in both GNU/Linux and Windows, without difficulty. There is no setting in the menu to fix the overscan (I have tried all of them, I realize it’s not always called overscan). I have been in the service menu for the TV, which still does not contain an option to fix it. No aspect ratio settings, etc. The TV has a VGA connector but I am unsure if it would fix it, as I don’t have a VGA cable long enough, and am not sure it would get me the 1920x1080 resolution which I want. Using another resolution does not fix the problem.

I tried custom modelines with the dimensions of my screen’s viewable area, but it wouldn’t let me use them.

Ubuntu apparently doesn’t automatically generate an xorg.conf file for use. I read somewhere that modifying it may help solve it. I tried X -configure several times(with reboots, etc.) but it consistently gave the following error messages:

In log file:


(WW) Falling back to old probe method for vesa
Number of created screens does not match number of detected devices.
Configuration failed.

In output:


(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
Configuration failed.
Server terminated with error (2).
Closing log file.

Tried using 'overscan' prop in xrandr:

root@xxx:/home/xxx# xrandr --output HDMI1 --set overscan off
X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 11 (RRQueryOutputProperty)
Serial number of failed request: 42
Current serial number in output stream: 42

'overscan on', 'underscan off', 'underscan on' were all also tried.

Originally tried with Ubuntu 12.04, but failed and so updated to 12.10 when it was released. All software is up to date.

Update: I just bought a new TV and the new one has plenty of options for fixing this, so for me it's resolved. Still interested to know of a solution for this absurd problem that shouldn't be though.

share|improve this question

4 Answers 4

It may be that your Intel graphics do not support the xrandr underscan - you can check this by trying:

xrandr --prop

...this should list the properties available, and report the status of things like underscan, if it exists.

Our Intel Celeron J1900 (SoC with graphics on chip) appears to be using the i915 kernel module and does not have many features on offer at all, according to xrandr. Not underscan, anyway. (sigh)

About to try 'xvidtune', but it comes with dire warnings of potential hardware damage...

Hope you find a solution!

share|improve this answer
    
xvidtune is not the answer, it seems. Have excercised it pretty thoroughly but to no avail. Ditto the xrandr --transform option. It may be that I've missed something, of course... –  Flymo Jun 25 at 12:15

I have the same problem, this trick works for me on an Intel HD 3000 with a cheap 720p Akira TV:

xrandr --output HDMI1 --set audio force-dvi --mode 1280x720
share|improve this answer

First, install latest Intel driver.

Add the following to /etc/rc.local:

intel_panel_fitter -p A -x 1200 -y 670

and in the users .xprofile:

xrandr --output HDMI1 --transform 1.0,0,+1,0,1.0,+2,0,0,1

Now the picture goes through DVI -> HDMIAdapter -> Samsung TV.

Xrandrs transform option alone did not help.

share|improve this answer

I've been having the exact same issue with my laptop with an Intel 4000 / NVidia GTX 680M setup. Due to this issue, I was booting to my windows drive just for watching movies and whatnot. Recently installed updates on my Windows side, and POOF!, couldn't adjust it there either...

I'm glad I fixed it at last: There was one particular setting on my TV that needed to be changed from it's default. It was buried pretty well in the menus and didn't know it was there until I was reading through my TV's manual to see if I could find more information to tune my graphics with.

There was an option in there that trimmed my display down to a perfect fit, and now everything looks perfect for me all around.

Just wanted to mention it in case you haven't gone through your TV settings thoroughly (I thought I had... THREE TIMES.) I feel really dumb for having LEARNED something from the manual for my TV, but I'm happy it's at least working properly now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.