Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have D-link DSL 2750U wireless router. My PC and notebook are connected to router by Wi-Fi. They can share files or ping each other. I have a network storage unit plugged into router by an ethernet cable. Any of the computers cannot reach that storage unit or ping it. I guess my router isolates LAN network from WLAN network. Is there a way to combine them and get the router treat all devices connected to router in a single network? Thanks.

share|improve this question
1  
Some routers have two VLANs that are built in; Main Wireless and Guest Wireless. Make sure that you're not connecting through the guest wireless. –  kobaltz Oct 29 '12 at 0:21
    
Isolation between LAN and WLAN is not standard behaviour for these types of router, but might be a setting you may have inadvertently enabled. If you plug another device into the LAN ports, are you able to connect to the NAS from it? –  Paul Oct 29 '12 at 0:41
add comment

2 Answers 2

your router shouldn't 'isolate' LAN from WLAN. As kobaltz said, make sure your not connected to the guest wireless, then try to connect to the NAS (Network Attached Storage) again. If not, check the IP of the NAS itself. If it starts with 169.254.X.X, you got a configuration error. It should start with 192.168.X.X. Try rebooting the NAS and router. Also, check your MAC address filtering, make sure the router is not blocking the NAS's MAC address.

If these solutions don't work, leave a comment and I'll look further into it. Good luck!

share|improve this answer
    
NAS already has 192.168.1.X IP address and I have no active MAC address filtering. I am not connecting to Guest Network as I am using WEP passphrase to connect that I created on router configuration panel. So I guess it must be something else. –  fiatux Oct 29 '12 at 12:25
    
how are you connecting to NAS? make sure to connect using this syntax: \\domain\default_path (for windows, not sure about Mac, will look into that) e.g. if the name of the NAS is myNetStorage, and you want the "home" folder to be the "shares" folder, then connect using `\\myNetStorage\shares` (you can just enter this into windows explorer to see if it works, if it does then add it as network drive). My brain is exhausted from big day, so sorry if it's confusing. In the meantime I need sleep –  Sylvester the Cat Oct 29 '12 at 12:34
    
Here's how you can map the NAS drive(s) on MAC If this doesn't help, or that's not the problem, just drop a comment with any details you may have figured out since you posted the question –  Sylvester the Cat Oct 29 '12 at 23:00
    
as i said, i can't even ping the ip, i get "host is not reachable" response. how can i map a drive i can't even ping? –  fiatux Oct 31 '12 at 0:07
    
any more ideas? –  fiatux Nov 11 '12 at 13:57
show 1 more comment

Disable "Enable MultiAP Isolation" setting under wireless network settings.

That worked for me on D-link DSL 2750U.

share|improve this answer
    
I don't have that option in my panel. Please see the screenshot here: f.cl.ly/items/2Z1q450P0B342h123p1x/… –  fiatux Apr 2 at 23:17
add comment

protected by Community Jun 1 at 9:06

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.