Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently purchased Windows 8 Pro and installed it with no problems. However, I am only able to change my wallpaper to either a solid color, or the default flowers picture. I can't use a custom image or one of the built-in images.

I can modify the theme's color, sounds, and screen saver, but when I try to change the background, it will automatically revert to the "Windows" theme. If I attempt to choose another built-in theme such as "Earth" or "Flowers", it will also revert to the "Windows" theme.

I found this thread after a quick Google search which tells me to delete a file called TranscodedWallpaper, but, after doing that, when I try to change the theme or background, it'll once again revert to the "Windows" theme and then the file I just deleted gets recreated.

This seems like a trivial problem, but nothing that I've tried has been successful. Sure, the daisies wallpaper is cute and all, but I'm more of an outer space guy.

Screenshots:

Notice how choosing an image doesn't change the wallpaper: enter image description here However, choosing a solid color does: enter image description here

More here: http://imgur.com/a/sGadp

share|improve this question
    
wallpaper for desktop or for start view? –  antonio081014 Oct 29 '12 at 1:47
    
It's for the desktop –  AlexRamallo Oct 29 '12 at 2:33
    
Probably it's better if you can post any graphic info here. –  antonio081014 Oct 29 '12 at 16:32
    
Here are a few screenshots: imgur.com/a/sGadp notice how choosing a solid color changes the wallpaper, but choosing an image doesn't. –  AlexRamallo Oct 29 '12 at 19:51
    
Have you tried "Browse" –  antonio081014 Oct 29 '12 at 20:15
show 4 more comments

7 Answers 7

up vote 4 down vote accepted

I have experienced this problem as well and the only solution is to change from a transcoded wallpaper file by doing this:

Search for %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes\, then right-click the file entitled "Transcoded Wallpaper," and then select "Rename". Change the name to "transcodedwallpaper.old".

Double-click the "slideshow.ini" file. This should automatically open in Notepad. Erase all text that appears in this file (if there is any), and then click "File," followed by "Save" in Notepad. copy your background Image, and rename it "transcodedwallpaper"

Then, go to "CachedFiles" and the default image there, remove it. Paste your background image and name it "CachedImage_1440_900_POS4" or the name of the previous image.

share|improve this answer
    
Two problems: There is no slideshow.ini file, and after I've copied in the new image and given it the name of the old image, nothing happens. If I try to change the wallpaper, the new image is deleted and replaced with the old one. Thoughts? –  Hubro Jan 10 '13 at 12:33
    
OK, my bad, slideshow.ini was a hidden file, but it's already empty anyway, and my problem persists. –  Hubro Jan 10 '13 at 12:35
add comment

Have you activated Windows yet? Apparently, Windows 8 won't let you change the wallpaper until it is activated. It will not show any error message; it will just ignore your selection.

Yesterday I did a clean install and tried changing the wallpaper (before activating) and it didn't work. Same exact symptoms as you; it would automatically revert back to the "Windows" theme, no matter what I choose. Once I activated Windows and rebooted, changing the wallpaper worked perfectly.

I'm not 100% sure, but I think Windows 7 did this too.

share|improve this answer
add comment

Here is a way to change the desktop background to what you want. This has to be done the same way each time when you want to change the background, and only the "Fit screen" choice will actually work. Also, you will need to download TakeOwnership.zip, as you'll need it to eventually change the background.

  1. Right-click your desktop and select Personalize
  2. Select the Basic theme
  3. Close Personalization
  4. Go to C:\Windows\WEB\WALLPAPER\Windows, where you will find the background image - it's a file named img0.jpg (note that it's in fact a BMP)
  5. Right-click on this picture and from the context menu select "Take ownership"
  6. Copy your desired background image into this directory
  7. Rename img0.jpg to img.jpg (no need to change the file extension)
  8. Rename your own picture to img0.jpg (again no need to change the extension)
  9. Right-click on your picture and from the context menu select "Set as desktop background". The screen will turn black.
  10. Now rename your picture back to img1.jpg and rename the original picture back to img0.jpg
  11. Exit the directory and repeat steps 1-3

And there you have it, your desktop background. You can change colors etc. freely but not the image itself afterwards. Also you can not change the image position to "Fit to screen" or any other setting.

share|improve this answer
add comment

I figured this out after reading your first post: where you see the file transcodedwallpaper, open the folder 'CachedFiles', and replace the image in that folder with the image you want as your background, whilst keeping the same name.

share|improve this answer
add comment

Have you tried to assign a wallpaper outside the default windows "theming" utility? (the one you show us in screenshots).

Personally, whenever I want to assign a wallpaper, I rather open the image in some image viewer (e.g., IrfanView, FastStone Image Viewer, etc), and then choose the option of that app to set the image as wallpaper.

Another idea is trying to set an image as wallpaper directly from your browser. Simply right click any image in the browser (you can even open local images in it), and choose "Set as desktop background" or the like.

Tell me if that works.

share|improve this answer
add comment

Go to Desktop -> Right Click -> Personalization -> Desktop Background -> Browse -> (Then choose whichever background you want) -> Profit :)

I'm assuming you're talking about the Desktop background since you mentioned daisies.

share|improve this answer
    
That doesn't work, It still reverts to the default theme. –  AlexRamallo Oct 29 '12 at 1:10
add comment

Your copy of Windows is not a final release, then. Users who downloaded their OS from torrents have been experiencing such an error. Google it. You probably own a pirated version of windows 8. Check with your distributor.

share|improve this answer
4  
I bought it directly from Microsoft using their Windows 8 Upgrade Assistant, and I have the receipt to prove it. –  AlexRamallo Nov 7 '12 at 3:44
    
-1 Not only is this answer inaccurate, but also prejudicing the OP about using pirated software was uncalled for. –  Daniel Liuzzi Dec 24 '12 at 2:13
    
i agree you cant accuse somrobdy of piracy without proof –  ben950 Feb 7 '13 at 14:50
add comment

protected by Community Feb 8 '13 at 14:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.