Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was running an amd64 build of Ubuntu on a VM on a Windows host which was also amd64. Later I found I could not run the same amd64 iso on my laptop, which is intel without hyper-V. I was confused I thought chipset mattered, but maybe it does not.

When buying a PC or Apple, is there anything to check about the chipset to make sure it can run different types of VMs?

In my case, I was trying to run ubuntu on a Thinkpad T520. Per answer below, I did need to enable some bios settings. I'm still having some issues. Running ubuntu on virtual box, when I try to use ubuntu-12.10-server-amd64.iso for the CD/DVD device to start a new VM, virtualbox complains "Failed to open the CD/DVD image . Could not get the storage format of the medium (VERR_NOT_SUPPORTED). When I try to use ubuntu-12.10-server-i386.iso the ISO is accepted, but then the VM complains "FATAL: No bootable medium found! System halted."

I had been using an amd64 iso on my home PC which is amd64 and it works fine, which is why I suspected CPU mismatch was the problem at first. But it seems like I'm having issues, and maybe this superuser thread can be used to verify the cpu is irrelevant in this case.

share|improve this question
    
AMD64 = X86-64 = Intel or AMD chip that supports 64 bit. Either your laptop does not have a 64-bit capable CPU (which is very rare these days) or it simply failed to boot because of configuration problems. Why is hyper-v involved here? Did you try to run it in a virtual machine in your laptop or on the physical machine? What VM software did you use? What steps were taken? –  billc.cn Oct 29 '12 at 1:59
    
Without you specifying the specific CPU / model of hardware, we can only guess that the model is new enough that the Intel chip inside is 64 bit. The real question would be does Ubuntu's amd64 build run on the Intel chip in question? (as it doesn't really matter that the Intel mother board is inside a Mac or other vendor's box since the virtualization software should take care of any Mac specific drivers.) –  bmike Oct 29 '12 at 3:26
    
I tried things on Thinkpad T520. nerdwaller was right that I needed to enable virtualization from the device, though I'm still have problems running the ubuntu ISOs I'm trying (both i386 and amd64 versions). –  Frank Schwieterman Nov 4 '12 at 22:44
    
I was not being specific about what type of macbook as I may get one in the future but do not know what type. It would be new and shiny, though. –  Frank Schwieterman Nov 4 '12 at 22:45

1 Answer 1

That really depends.

To part 1: Does your laptop have Virtualization Support? That is required (and may just be disabled in the BIOS if it's non-Apple). If that's the case, on boot you could hit DEL or F2 (or check your boot screen for which key it is) and check the Bios pretty quickly. What model of laptop/CPU do you have?

For example, Intel's site with specs will show:

enter image description here

To part 2: Yes, every Apple I have seen has processors that have Virtualization enabled, so they should run VMs.

If it's a software issue, try VirtualBox. It's free and cross platform. amd64 just means 64bit, that's because AMD made the technology and licenses it.

Edit (after OP update):


First, I want to digress and say: Great choice on a laptop, I have a t530 and it has been my favorite computer ever.


Now on to business...

Can you check the MD5 (or SHA1) checksum on the ISOs you have? I had that issue before and it was because it was a broken ISO. But I am sure that could be other issues too (one being your Kernel may not be loading the necessary components).

My second thought is when I had that issue it was because I installed Windows with Virtualization disabled and did not work until I installed windows with Virt. enabled in my Bios first (I have no idea why).

Of course, this person after adjusting the setting suggests I was incorrect and says to just change the setting and shut down for 5-10 seconds before booting. I can't verify that though because I no longer have the issue.

share|improve this answer
    
Thanks. You're right I needed to enable BIOS options. I am using VirtualBox. I'm still seeing errors, I'll post the results. –  Frank Schwieterman Nov 4 '12 at 22:45
    
I will update my answer accordingly! –  nerdwaller Nov 4 '12 at 22:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.