Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently bought an Asus X401A laptop. For some reason, I cannot get internet access on the wireless connection. The wireless connection succeeds and I can see other computers on the network once connected. If I run ipconfig, I get a good IP and the default gateway is right.

Some info that may help:

  • Running Windows 8 (Had the problem when it was Windows 7, but thought upgrading may help)
  • Comcast is my ISP and I'm using the router that they supplied
  • Connecting with an ethernet cable works fine and does allow for internet connectivity.
  • Authentication is WPA2/AES, but tried with no authentication as well
  • The default gateway is
  • Network adapter is by RaLink
  • Tried getting latest version of RaLink driver
  • Windows 8 install switched network adapter driver. Now uses Microsoft driver
  • Windows network troubleshooter does not solve the problem (just says default gateway unreachable)
  • Tried to connect at a public wifi hotspot and it worked just fine
  • Have several other devices connected (pc, ipad, ipod, tv, wii, phone, etc...) to the same router with no problem
  • Tried rebooting the router
  • Tried resetting router to defaults
  • Confirmed that there is no mac address filtering enabled
  • When connected, network comes up as unidentified and I'm never given the option to designate the network as a Home network
  • Pinging the default gateway times out
  • Tracert to the gateway IP returns "Destination host unreachable"
  • USB wifi adapter from the same laptop works fine
  • Turned off IPV6 for the adapter
  • Tried manually setting all of the IPV4 configuration (default gateway, dns servers, etc..)

Any suggestions would be appreciated.

share|improve this question
You forgot to describe the problem! Your question says something about a default gateway not found, but your problem description says that default gateway is right. So what's the actual problem? Can you ping the gateway? Can you traceroute out by IP address? What goes wrong? – David Schwartz Oct 29 '12 at 2:35
Generally, If a wired connection works but a wireless doesn't, it could be a driver issue. – Jay Oct 29 '12 at 3:15
@DavidSchwartz - Thanks for the reply. The root problem is that I have no internet connectivity when I'm connected wirelessly. The windows troubleshooter returned the response that the default gateway is unreachable, but if I run ipconfig I see the correct default gateway listed. If I ping the gateway IP, it times out. Tracert for the gateway IP returns destination host unreachable. – Paul G Oct 29 '12 at 10:19
@Jay - I thought so too, but I've updated the RaLink driver to the latest. That didn't work. I've also used the windows supplied driver and that didn't work. Wireless also works with internet on other networks. – Paul G Oct 29 '12 at 10:41

With all the tests you have done, one has to conclude that your computer's wireless adapter just cannot manage to work with your router. I hope you have tested with the computer in the same room as the router.

If the wireless adapter has any way to set parameters, maybe using a manufacturer utility that came with the computer, then do so. Or such a utility may be available for download on the manufacturer's website.

Otherwise, try changing some parameters on the router, such as channel or security settings. You could also try using some other router and see if this works.

Try also to turn off the Windows firewall, just in case.

If all fails and if the computer is still under warranty, ask the vendor for the wireless adapter to be replaced.

share|improve this answer
Though I would suspect the router at home first. I am experiencing a similar issue and I have determined it is my router as I have the same problem with multiple computers on the same cable. – Sarge Nov 8 '12 at 17:20
Better also check if a firmware update exists for the router. – harrymc Nov 11 '12 at 9:22
@harrymc - Thanks for your response. I've tried every combination of router and wireless adapter settings that I could find. I've started to find several posts in various places online that indicate that there is a problem with the communication betweek Ralink adapters and this particular Arris modem/router that Comcast supplied. I'm going to see if comcast will push me a firmware update or replace the router. Plan B will be to go buy a modem/router and turn in the rented one from Comcast. – Paul G Nov 12 '12 at 19:08
Have you tested with no encryption (clear) ? – harrymc Nov 12 '12 at 19:16
@harrymc - Yes I have. Same result. Thank you. – Paul G Nov 13 '12 at 18:27

Maybe another suggestion would be MAC address filtering. On my router, in order for a device to connect to the router using Wi-Fi signal, the wireless network adapter's MAC address has to be entered into the router's configuration page. Most of the time, MAC address filtering is not on by default, so unless you turned on MAC address filtering, this probably wouldn't be the solution. But, worth a shot.

share|improve this answer
Thanks H3br3wHamm3r81. I did check the MAC address filtering. It was not enabled. – Paul G Nov 12 '12 at 19:04

I suspect your wifi adapter is not win8 compatible/supported. I suspect the cure is to downgrade the operating system, or upgrade the wifi adapter, until you have a matched pair. Good Luck....

share|improve this answer
up vote 1 down vote accepted

The problem turned out to be that RaLink wireless adapter is incompatible with the Arris router/modem that Comcast provided. I eventually found someone at Comcast that comfirmed that this was a known issue with the Arris router model that I was given and that they were waiting on a firmware update from Arris. I bought a Motorola SurfBoard, turned in my rental router/modem, and connected a NetGear wireless router and all is well.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .