Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Windows 8 Professional 64-bit in a VHD that dual boots with Windows 7. The VHD is dynamically expanding with a 128 GB capacity.

When windows 8 reboots, it seems to get stuck in an infinite loop and will say "Restarting" while the five dots circle around for hours and hours. When I use the power button to force it to turn off, it sometimes says, "Your PC ran into a problem". This error message tells me absolutely nothing that I don't already know. What happened to useful error messages?

If I use the command line shutdown /r /f /t 0 it actually reboots. Is there a way to set the default arguments?

share|improve this question
    
Are you sure you want to be using shutdown /f? A forced shutdown could cause problems with some properly functioning programs as well. –  Jay Oct 29 '12 at 3:13
    
The problem occurs on reboot every time the /f switch is not used, but it never occurs if the /f switch is used. shutdown /s works correctly without the /f switch. Only reboots are affected. –  ctype.h Oct 29 '12 at 4:09
    
@Jay I have been using Windows 8 Pro for about 2 weeks and have not had any problems with programs not working correctly. –  ctype.h Oct 29 '12 at 4:11
add comment

2 Answers

up vote 2 down vote accepted

It seems the best solution is not to use VHD boot. After reinstalling Windows 8 directly in a partition on my hard drive, the problem has been resolved.

While VHD boot is a cool feature, unfortunately it seems that it is not yet ready for serious use.

share|improve this answer
add comment

Create a new .bat file called shutdown2 containing the following

shutdown /r /f /t 0

Put it in a folder of your choice, I.E. C:\scripts and add that location to your Path variable. Easiest way to do this is

  1. Win + W
  2. Type system environment variables
  3. Enter
  4. Environment Variables
  5. Under System variables select Path and click Edit
  6. Scroll to the end and add ; C:\scripts. The semicolon is necessary because it separates it from the previous entry

Now you can run shutdown2 just like any other command, either in command prompt or through Win + R.

share|improve this answer
    
I already have a batch file called reboot.bat with those arguments. I was hoping to set the default arguments in the registry so that when programs (e.g. Windows Update) decide I need to reboot, the machine does not end up stuck in an infinite loop in case I forget to cancel the reboot and enter the command manually. –  ctype.h Oct 29 '12 at 2:41
    
You could try renaming shutdown.exe in C:\Windows\system32 to shutdown2.exe and placing your new file in there. The only caveat is that some programs might expect it to be a .exe file instead of a .bat and some programs won't even use shutdown.exe. There are many ways to shutdown/restart a computer. –  Caleb Jares Oct 29 '12 at 3:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.