Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Textmate on OS X Lion and I used to be able to use Shift+Alt+W to

"Wrap selection in open/close tags"

but this no longer works for me. Instead I get a weird double comma character when I press this:

When I press Shift+Alt+Q I get this one:

Œ

How can I disable extended keyboard characters in OS X Lion?

I think my Keyboard & Language Preferences are ok, I only have US English keyboard selected:

screenshot-with-shadow.png

Screen shot 2012-10-28 at 10.38.10 PM.png

I also have this unchecked:

Picture 1.png

I'm using a BlueTooth keyboard but this also happens with my regular keyboard.

I'm running BetterTouchTool and I have KeyRemap4MacBook installed but these do not seem to be the problem.

Here is the debug from the KR4MB event viewer:

Picture.png

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Keyboard shortcuts generally use the Ctrl or Cmd keys to prevent overlapping with regular character input.

However, keyboard shortcuts for application functionality overrides the equivalent character input.

If you want to remove those from your keyboard layout anyway, you can gut all special characters from a keyboard layout using Ukelele. Just load your usual layout, remove everything you don't want, and save under a new name. Select it in System Preferences » Language & Text » Input Sources.


Note that my TextMate shows the keyboard shortcut Ctrl-Shift-W, and I don't remember it ever being Alt-Shift-W. The menu item is in Bundles » HTML, or you can just type the label in the menu item search in Help to see it.

Screenshot

share|improve this answer
    
So you're saying that applications don't generally use Alt/Option with a letter key as a shortcut key? Interesting. I never noticed that before. Thanks. –  cwd Oct 29 '12 at 13:05
    
@cwd Not usually, because these are mapped to special characters. –  Daniel Beck Oct 29 '12 at 13:32

The characters you mention for shift-alt-W and shift-alt-Q are the default keys and not something the OS lets you disable in one fell swoop.

There are two viable options that I see:

  • Using the standard keyboard shortcuts mechanism in the Keyboard preference pane to assign the keys one-by-one to the system or the app as you please.
  • Using KeyRemap4MacBook to actually change the underlying keyboard mappings once you've figured out how to craft a custom private.xml file that leaves these key mappings alone on the system level so that they will flow through to your apps as you desire.

The event viewer tool will assist you in determining the result of your key-presses and help with copying these results to the clipboard.

share|improve this answer
    
Interesting. Is this new in 10.7 vs 10.6? I remember in SL they used to work... –  cwd Oct 29 '12 at 3:03
    
It's certainly in effect for 10.7.5 and 10.8.2 - and I don't have a 10.6/Snow Leopard system handy. It sure seems like something that came in with Lion and the Special Characters... menu item system wide. It also could be tagging along with the introduction of services in Lion. –  bmike Oct 29 '12 at 3:22
    
I really wish there was some way to disable this either per application or system wide. It seems the keyboard shortcuts menu in Preferences has no effect on changing this - I tried adding the menu item with the same name and keyboard shortcut but it didn't work. The KR4MBP would probably work but it seem also quite convoluted. I bet maybe Daniel Beck or slhck would have some thoughts on this one... –  cwd Oct 29 '12 at 3:25
    
KR4MMP scares me each time I consider using it, and then I decide I have better yaks to shave and just re-train my brain to avoid running it. Lots of people swear by that package, but sadly I end up wanting to swear at it. –  bmike Oct 29 '12 at 3:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.