Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a computer display plugged into a DVI port, and TV plugged into the HDMI port. Whenever I turn the TV on it becomes monitor #1.

This is more of an annoyance than a problem, as I can make my computer display the "main display".

The annoyance is that it makes the Windows UI not make sense.

Second Screen
Here selecting PC screen only turns of my computer display, and selecting Second screen only turns of my TV.

I have tried editing the registry, and the suggestions here, but none of them work. As soon as I plug in my TV, it becomes monitor #1.

Based on what I've heard from other people with the same problem, it seems like HDMI will always take over as #1. Is that so?

Is there any way to correct it?

share|improve this question
see… – ronalchn Oct 29 '12 at 3:23
@ronalchn I've read that UltraMon doesn't actually change the numbers. Plus, not exactly a $40 problem. – Louis Oct 29 '12 at 3:26
I am not advocating ultramon, I just linked to it because it appears there is no solution – ronalchn Oct 29 '12 at 3:31
I have the same problem and it is a PROBLEM because after sleep the desktop is shown only on the Display 1 (that is, TV). – Anixx Nov 7 '14 at 9:49
@Anixx What I wound up doing is using a DVI to HDMI cable which I run to the TV, and using DisplayPort with the monitor. Things work out this way... =/ – Louis Nov 7 '14 at 23:01

Same issue for me. Seems that TV through HDMI always wants to be #1 display. Although I don’t have any troubles with bootup or something else.. All perfectly fine except for Win+P menu. It completely mess around. So I decide to cheat the system by editing resources.

I have English Win7 SP1 64bit (build7601) 96dpi. With two monitors connected: DVI for PC and TV through HDMI If you have same setup you can repeat my way relatively safe. But you MUST to know how to take ownership or boot from LiveCD. If not please don't do it. you can end up with unbootable PC (worst case)

Here is the files, just replace originals (you must to know how to.. if not, don't do it.) And don't forget to backup originals. I also replaced icons to win8 style.

This solution only for logical and good looking Win+P, and don't have any relationship to displays identification. (so it's even more mess from the system point of view) I'm sorry for win7 answer to win8 thread. But this thread is very high at google search. Maybe some one find my solution helpful, I'm spent more then a hour to change resources and write this guide.

Edit: Now I have got some reputation and can attach an image

enter image description here

share|improve this answer
If the setting is to display the desktop only on one monitor, then after sleep the desktop is displayed only on monitor #1 (even if the setting was to display it on monitor #2). That is the desktop is only on the TV. Since the TV is in another room, I have to make a hard reboot every time after sleep. This is regardless what monitor is "main". – Anixx Nov 7 '14 at 9:57

No, you can change which display is your main display. To do this go to

Control Panel\Appearance and Personalization\Display\Screen Resolution

either by right clicking on the desktop and selecting Screen Resolution or by hitting Win + W and searching for it.

You will get this screen. Click on the appropriate monitor and check Make this my main display

enter image description here

share|improve this answer
This is what I've done, but it doesn't fix the issues I've described. – Louis Oct 29 '12 at 3:27
"This is more of an annoyance than a problem, as I can make my computer display the 'main display'." – Louis Oct 29 '12 at 3:28
Strange, I have 2 monitors through DVI and mini-displayport and one of them is set as the main monitor. When I turn on the TV I go to these settings and click Detect and it switches to my main monitor and the TV. – Caleb Jares Oct 29 '12 at 3:29
Sorry, I skimmed your question. – Caleb Jares Oct 29 '12 at 3:30
Sounds like a Windows bug to me. – Caleb Jares Oct 29 '12 at 3:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.