Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 8 on a Retina MacBook through Parallels.

When I open the "Metro" Chrome application (i.e. click on the chrome tile to launch) the browser renders beautiful crisp content, but when I run Chrome from the desktop (i.e. run the desktop application and double click the Chrome icon on my desktop), content in the browser is slightly fuzzy.

Is there a way to make Chrome look nice regardless of how I launch it?

share|improve this question
add comment

4 Answers

up vote 7 down vote accepted

This appears to be a bug (reported in Google Code here and here) within Google Chrome currently, having to do with Windows using display scaling when a MacBook Retina (if you're using high-DPI modes and display scaling at 150% or higher, which is the default).

Although coming at a slight compromise, you can disable display scaling for Google Chrome specifically. This will render the fonts correctly, but all of the controls in the "omnibar" (back, forward, reload) are extremely small.

Here's how:

  1. Right-click your Google Chrome shortcut and click "Properties"
  2. Move to the Compatibility tab
  3. Check the box that states "Disable display scaling on high DPI settings"

And click OK. Screenshots below from the reported issue.

Google Chrome Properties (Right-click, Properties, Compatibility)

Google Chrome Properties

Google Chrome without rendering issues, but small controls

Google Chrome- not fuzzy

share|improve this answer
    
Thats an oddly large properties screenshot - is this a retina MBP thing? I've seen a few elsewhere. –  Journeyman Geek Oct 29 '12 at 7:29
add comment

In addition to disabling the scalining on high DPI devices you should adjust the scaling of web content inside of chrome. Won't make the omnibar or favorites bar any bigger but it will scale pages really well.

Settings -> show advanced settings -> web contents (175% works on well for me)

share|improve this answer
add comment

In my case, adjusting the size settings, fixed the issue. I had already done the compatibility fix mentioned in the answer below.

When the problem still persisted, I found these options, in the Display tab of the control panel. The options shown in the image, will turn up only after u check the "Let me choose one scaling level for all my displays" checkbox

enter image description here

share|improve this answer
add comment

Chrome doesn't offer support for retina at the moment:

http://www.hongkiat.com/blog/mbp-retina-blurry-text/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.