Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 8 on a Retina MacBook through Parallels.

When I launch Mozilla Firefox, all web content is shown really small on my screen. For example, this website takes up about a third of the horizontal screen real estate available.

How can I show web content at a reasonable size? Do I have to zoom right in every time I open the browser?

share|improve this question
    
You're saying you have to re-zoom in every time you open up Firefox? –  Caleb Jares Oct 29 '12 at 5:51
    
I have to re-zoom for every new website I visit. Zoom level also seems to be lost between reboots. –  kristian Oct 29 '12 at 5:54
    
Is it just FF that's acting this way, and fine in IE? –  Karan Oct 29 '12 at 5:55
    
FF is the only browser with this issue. IE and Chrome are not affected. –  kristian Oct 29 '12 at 5:56

3 Answers 3

up vote 4 down vote accepted

Instead of the addons Caleb suggested, you could fiddle with Firefox's configuration. Navigate to about:config. Use the search bar at the top of the page.

  • layout.css.devPixelsPerPx

    This controls pixel scaling. Change to a higher value to enlarge everything in the Firefox window.

  • browser.zoom.siteSpecific

    This turns off site specific zoom, so one zoom level is used across all sites. Caleb's suggested addons allow finer control, with a default global zoom in addition to site specific zoom.

share|improve this answer

Firefox V22 (June 2013) now has support for high DPI settings in Windows so you no longer need to preform the config changes. It will correctly scale by default.

If you have made the suggested DPI change in Firefox, just update Firefox and go back into

about:config

Find the settings you changed, right-click and select "Reset". You'll now be back to standard config.

You'll also see the Firefox app menus are now correctly sized and laid out. :)

share|improve this answer

Some possible solutions

  1. Reset Zoom by pressing Ctrl + 0 (zero key)
  2. Install the Default FullZoom Level AddOn
  3. Install the NoSquint AddOn

Source. You can find more information here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.