Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some old games that I would really like to play run slowly on some graphic drivers when Direct3D acceleration is enabled.

I have tried many suggestions but none seem to work. The only thing I have not tried is disabling Direct3D acceleration. Is it possible to disable DirectDraw and Direct3D acceleration on my Windows 8 PC?

From InterAction Studios:

There are certain bad versions of GeForce drivers that cause this problem. This is a problem in the drivers themselves and is unfortunately completely outside our control. The recommended way to fix this problem is to update your graphics card drivers (go to NVIDIA's web site for this).

Alternatively, there is a workaround that alleviates or solves the slowdown problem altogether.

Try this: Right-click on your desktop and select "Properties". Go to the "Settings" tab and click on "Advanced...". Click on the "Troubleshooting" tab and move the slider to the left until it says that all DirectDraw and Direct3D accelerations have been disabled (around the middle of the range). Finally, click on "OK".

Note that this workaround might cause other games on your computer to slow down, so you may have to switch back and forth between settings, but it's certainly worth a try if you can't obtain an updated graphics driver.

share|improve this question
1  
Do you have real reason for wanting to do this? –  ChrisF Oct 29 '12 at 9:48
1  
@ChrisF I used this to fix the colors in StarCraft on the old Intel integrated graphics. –  Mikhail Oct 31 '12 at 6:53
1  
Your problem is less likely DirectDraw and DirectX, and more likely to do with the WDDM 1.2 driver model that's preferred in Windows 8. –  Ƭᴇcʜιᴇ007 Nov 11 '12 at 19:22

3 Answers 3

up vote 3 down vote accepted
+100

Its possible I did it .(Successfully tested on Windows 8 RTM)

Steps:

1. Disable Aero(Mostly not necessary but do it for now) Disable aero

2. Download directx 9.0c control panel from here

3. Extract and run "directx.cpl" as administrator.

4. Goto Direct3D and DirectDraw tabs and uncheck "Allow hardware acceleration ". directx control panel

5. Run dxdiag from Directx tab else from run command and check status dx status

share|improve this answer
    
Why is it in high contrast? is it necessary? –  pratnala Nov 12 '12 at 10:47
    
no i have kept it .. its not necessary at all ... –  swapyonubuntu Nov 12 '12 at 11:59
    
After doing this, I have the same results.. BUT If I run DxDiag in x64 mode (from the system tab) it shows that Both DirectDraw and Direct3d are enabled....! Any ideas on how to disable them there? –  Odys Nov 29 '13 at 8:18

It cannot be done -- Windows 8's entire UI uses the DirectDraw/Direct3D acceleration interface.

share|improve this answer
2  
How about safe mode? Traditionally, that disables DirectX. –  Bob Oct 29 '12 at 9:31
    
@Bob - Sure...Its disabled there but so is pretty much every other service that is required for daily use. –  Ramhound Oct 29 '12 at 10:53
    
@Ramhound I can't imagine any reason for disabling DirectX except debugging. And it does indicate that it can be done - even if not in the most desirable way. –  Bob Oct 29 '12 at 10:54
    
I'm pretty sure that's not true. –  SLaks Oct 29 '12 at 16:43
2  
If you're not entirely sure it can't be done, I wouldn't post this as an answer. I've reopened the question, but I'd leave room for others to answer. –  slhck Oct 29 '12 at 17:58

Have you tried the good old registry keys?

Reg Add HKLM\SOFTWARE\Microsoft\DirectDraw /V EmulationOnly /T REG_DWORD /D %_Mode% /F
Reg Add HKLM\SOFTWARE\Microsoft\Direct3D\Drivers /V SoftwareOnly /T REG_DWORD /D %_Mode% /F

These can be automated as outlined in the following post:

http://www.techsupportforum.com/forums/f10/shortcut-batch-file-code-to-disable-direct-draw-acceleration-437584.html

Also, isn't it still in the compatability wizard as "ForceDirectDrawEmulation"?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.