Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I right-click the screen in the Windows 8 News app, all I see is Sources and Worldwide news; no My News section. I can’t seem to add any new sources or change any of the existing views.

Does anyone know how to fix this?

share|improve this question
    
What version is it? (on the Charms bar, go to Settings => About) What language is it set to? Which country are you in? (The News page in the store says Note: Some features and enhancements may not be available in all markets) –  Bob Oct 29 '12 at 10:29
    
I was not using the US locale. Seems to work better now that I switched the locale. –  efdee Oct 29 '12 at 10:58
    
Seriously? You've got to be in the US locale for this to work? That's absurd. –  therefromhere Feb 2 '13 at 22:14
add comment

1 Answer

up vote 3 down vote accepted

The My News section is there, see the video at Windows 8 guide: How to use the News app.

The relevant part of the video says:

Right-click on an empty part of the screen, and click My News.

After right-clicking, a menu appears:

enter image description here


If the My News section does not appear, then try to change your application content region/language to US (source News app - Can't change/delete/add sources).

Please add the my news option for all regions or the ability to add own feeds to it, otherwise tha app is useless outside the us.

-DieterDWorks In reply to YETWO post on September 18, 2012


  1. Open News app
  2. Press Windows + C
  3. Go to "options" and change "App language and content to" to some other setting and restart the news app

-YETWO

share|improve this answer
    
Like I said, when i right-click the screen, I only get 'Sources' and 'Worldwide (English)". Also no Bing story of the day or Bing news or whatever. –  efdee Oct 29 '12 at 10:19
    
I appreciate the screenshot, but as I said, I don't have "Bing Daily" or "My News" there, only "Sources" and "Worldwide (English)". –  efdee Oct 29 '12 at 10:26
    
@efdee - This sounds like a regional problem. –  Ramhound Oct 29 '12 at 10:48
    
Changing the locale to the US fixed the problem. Kind of sad. But at least I can set the locale for the News app separately. Thanks! –  efdee Oct 29 '12 at 10:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.