Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

With Windows 8, why isn't a mapped drive available under an elevated cmd prompt but is under a regular cmd prompt? I can run a net use and get it to be available but I still find this odd.

share|improve this question

migrated from serverfault.com Oct 29 '12 at 10:51

This question came from our site for professional system and network administrators.

marked as duplicate by slhck Sep 5 '13 at 5:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Are you elevating the command prompt as the same user or are you using runas or alternate credentials? –  MDMarra Oct 8 '12 at 22:22
    
Does the elevated user have the appropriate Share and NTFS permissions on the share? –  joeqwerty Oct 8 '12 at 22:32
    
Ask Microsoft support. –  John Gardeniers Oct 29 '12 at 10:51

3 Answers 3

up vote 11 down vote accepted

When using UAC with an administrative user, at login, Windows creates two tokens. One token (the elevated one) is unfiltered, and has the Administrators group enabled. The other token has the Administrators group (and some other details, like the Power Users group) filtered out.

Since these two tokens have separate security contexts, network connections in one aren't available in the other, even if it's really the same user.

So if you map a drive using Explorer, an elevated Command Prompt (or any other elevated process) won't be able to see it.

You can map the same network resource (using the same drive letter, even) in your elevated Command Prompt using the NET USE command. After that, any elevated process will also be able to see it.

share|improve this answer
1  
Is there a way to use Explorer AND have the drive be visible to all users? –  JimDel Oct 9 '12 at 14:19
3  
net use e: \\computerName\folder password /user:domain\username /p:yes is the commanded I ended up using that made it work. (Where e: is the drive letter you are mapping, \\computername\folder is the path to be mapped, and password, domain and username are the normal credentials to log-in. Hope that helps someone. I followed on example from here pcsupport.about.com/od/commandlinereference/p/… –  phyatt Mar 27 '13 at 23:15

William's answer explains why this happens and provides one workaround. But I want to add there is actually a registry fix from Vista that works in Windows 7 to adjust this behavior. Just add this to your registry:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"EnableLinkedConnections"=dword:00000001

After a reboot mapped drives should be accessible through the elevated command prompt.

share|improve this answer

Because you're elevating the command prompt as a different user, and the mapped drive in question was mapped by the non-administrative user. Different users have different user settings, like printers, mapped network drives and so on.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.