Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a device supporting FTP, connected to the office internal network via a router. Not sure it matters, but the device is Nano-10.

I followed their user manual, downloaded FileZilla and configured the connection per the instructions.

Note that the connection must use active mode.

The connection itself was successful and the client logged on successfullly; however when trying to get the files list, it timed out.

The user manual did mention this can happen and suggested to remove any Firewall and disable any Antivirus programs, which I did. No luck.

Here is the log from FileZilla:

Status:     Connecting to 10.1.1.7:21...
Status:     Connection established, waiting for welcome message...
Response:   220 Welcome FServer FTP.    
Command:    USER samples
Response:   331 Enter pass.
Command:    PASS *******
Response:   230 Log OK.
Status:     Connected
Status:     Retrieving directory listing...
Command:    PWD
Response:   257 "/"
Command:    TYPE I
Response:   200 OK.
Command:    PORT 10,1,1,27,207,166
Response:   200 OK.
Command:    LIST
Error:      Connection timed out
Error:      Failed to retrieve directory listing

All the above happend in my main machine, running Windows 7 (64 bit).

I have another machine in the same network running XP. Did the same steps exactly and it all works smoothly, including the LIST command.

What can cause such behavior? I guess it's something to do with the active mode (device won't work in passive mode so didn't even try) but can't figure it out myself. The only difference I can think of is the Windows Defender which is built in the Windows 7, but as far as I checked it does not act as Firewall.

Maybe worth to mention I also tried with other FTP client but to exactly the same behavior. The local reseller of the device (who gives the immediate support) said he also use Windows 7 64 bit and can connect without any problem (To his own device) so it doesn't look like a global problem with that OS.

share|improve this question

migrated from serverfault.com Oct 29 '12 at 13:51

This question came from our site for professional system and network administrators.

1 Answer 1

The FTP Client needs to be set to "Passive" mode. Otherwise FTP in "Active" mode (default) requires full routing (NAT router break this, like the ones everyone get for their house) and the ability to communicate with arbitrary ports (which most firewalls are too dumb to handle).

share|improve this answer
    
The manual clearly asks to choose "Active" mode. Also, it does work fine in XP. –  Shadow Wizard Oct 29 '12 at 13:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.