Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to use port 7777 for my dns web hosted site but i seem not to be able to connect to the website when i do that. It tries to log into my router? It brings up the user name and password to input to enter my router webpage.

If i use the default 80 port then my website comes up without a problem.

I have added the port to my routers port forwarding table with the servers IP both 80 and 7777 port (but not at the same time).

I've changed my bindings to use port 7777 in IIS manager.

I am also using No-Ip.com for my IP change (if it ever does).

How can i change the default port 80 to a custom port number without it trying to log into my router when i input my domain name url?

The no-ip settings i have to choose from is:

no-ip 1 or Port 80 Redirect? no-ip2 Not sure if that's the problem or not but if i change it to 7777 for Port Redirect it still does not work and changes my domain name from www.xxxxxx.com to xxx.xxx.xxx.xx:7777 which doesn't look nice.

My routers port settings: netgear

share|improve this question
    
You need to forward port 7777 to the IP that has the website. There are already a million answers on how to do this. Not even worth a downvote. –  ppumkin Oct 29 '12 at 15:03
    
@ppumkin: I have added the port to my routers port forwarding table with the servers IP both 80 and 7777 port (but not at the same time). –  StealthRT Oct 29 '12 at 15:06
    
Your tagging is a little misleading, what version of windows exactly are you using? –  Journeyman Geek Oct 29 '12 at 15:07
    
@JourneymanGeek: Windows Server 2012 but it seems to have the same setup as Win Server 2008 R2 from what i can tell. –  StealthRT Oct 29 '12 at 15:08
    
Ye- fantastic so what is the problem? –  ppumkin Oct 29 '12 at 15:08
show 8 more comments

2 Answers

up vote 1 down vote accepted

Set your router to listen to incoming web calls on port 80. Then forward it to your internal web server port 7777.

So your router will translate it from (wan)80 => (lan)7777 (hiding your webserver behind your router essentially)

http://www.myseupersite.com (always uses port 80)

https://www.myseupersite.com (always uses secure port 443)

enter image description here

Maybe untick use the smae port for internal port ? not sure...

share|improve this answer
    
AH! Now i get that. Thanks ppumkin. Do i do the same things if i have another website hosted on the same server? As in aaa.com->80->7777 and bbb.com->81->7000. I guess i would have to change 80 in no-ip to 81 for that domain name, right? –  StealthRT Oct 29 '12 at 15:53
    
Yes- but if you use port 81 then the user HAS to enter mysite:81 - YOu can only every have 1 webserver(unless you have load balanced) or your internal links point to that. –  ppumkin Oct 29 '12 at 15:56
    
Yes, the Use the same port range for Internal port does need to be unchecked for the user to put their own port number in the box. –  StealthRT Oct 29 '12 at 15:56
    
If you want to have many servers then you will need to place your own DNS server to resolve the DNS names to the correct internal virtual IP's (more advanced and out of scope) –  ppumkin Oct 29 '12 at 15:57
    
ok good to know. Thanks for the help. –  StealthRT Oct 29 '12 at 15:57
show 1 more comment

changes my domain name from www.xxxxxx.com to xxx.xxx.xxx.xx:7777

If your web server uses port 7777, that is what I would expect. You can get firewalls that can forward a request on one port to another, but it's less typical in cheap consumers routers.

share|improve this answer
    
boooooooooooooooooooooooooooooooooo -1 - he does not want to use blalalal:7777 –  ppumkin Oct 29 '12 at 15:54
    
No downvote needed @ppumkin. He replied to help. Thanks Joel! –  StealthRT Oct 29 '12 at 15:55
    
That the problem with these guys with high rep +15000 they think they can use their bots to upvote while giving sh*t answers –  ppumkin Oct 29 '12 at 15:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.