Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set Firefox to complete the address bar with elements from the history only ( other options are: nothing, bookmarks, and a history+bookmarks).

However, Firefox still continues to complete the address bar with elements that are no longer in my history. A search in the history returns 0 result for the incriminated string. How can I solve this without loosing my entire history? I have already tried shift+delete on the elements I would like to delete, without success.

How can I find the source of a certain completion ? (like an SQL request in the sqlite3 files used to store history)

I'm using Firefox 16.0.2 on OS X 10.8.2.

share|improve this question
    
Which version of Firefox, and which OS? –  user3463 Oct 29 '12 at 18:02
add comment

3 Answers

up vote 1 down vote accepted

For some unknown reason, certain URL are absent in the history, but are still used to autocomplete the address bar.

The raw information is stored in a file places.sqlite in the Firefox user directory.

Locate it, quit Firefox, and run this command to locate places containing the URL you don't manage to delete within Firefox,

$ sqlite3 places.sqlite 'SELECT *  FROM moz_places WHERE  moz_places.url LIKE "%example.com%"'

The following command will remove the URL you want Firefox to forget:

$ sqlite3 places.sqlite 'DELETE  FROM moz_places WHERE  moz_places.url LIKE "%example.com%"'

This request is incomplete as it leaves the moz_historyvisits table inconsistent. Feel free to improve it.

Hosts are also kept in the moz_hosts table, in places.sqlite and will be used for autocompleting.

share|improve this answer
add comment

This may be due to the links found in your bookmarks.

Search the bookmarks once, and delete the items from there.

share|improve this answer
    
Are you saying to delete the bookmarks to prevent Firefox from searching the history? –  Tanner Oct 29 '12 at 20:23
add comment

Try disabling autocomplete.

  1. Open a new tab and go to about:config?filter=browser.urlbar.autocomplete.enabled.

  2. Click "I'll be careful..."

  3. Find the browser.urlbar.autocomplete.enabled preference and double click it to set it to false.

share|improve this answer
    
But I want to use autocomplete.. –  Antoine Lecaille Oct 30 '12 at 9:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.