Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Sql Server Mangement Studio 2008 onto a Window XP SP3 machine. When I do, it says that I need to install .Net Framework 3.5 SP1. However, I all ready have .Net Framework 4.0 installed.

How can I work around this?

share|improve this question
up vote 1 down vote accepted

Application targetting .NET 3.5 SP1 need .NET 3.5 SP1 installed. .NET 3.5 SP1 by default installs .NET 2 and .NET 3.0. Basically the base CLR version is .NET 2. .NET 4 is a new version of CLR. Hence applications targetting .NET 4 will need .NET 4 installed and applications targetting older versions will not switch to .NET 4 without recompile.

share|improve this answer

Most versions of the .Net framework are not cumulative.
You need to install .Net 3.5 with SP1.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .