Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had the bright idea to install Windows XP Mode in order to try to solve this problem from yesterday. It seemed to work nicely, but as part of the new Virtual PC and Windows XP Mode installation, I had to enable the Intel virtualization support in my BIOS. With it enabled, I could use XP Mode just fine. However, when I tried to start my VMware VMs which existed prior to my installation of XP Mode, the VMware VMs failed to start. Instead, VMware Workstation (6.5.2) gave me a discouraging error message. This message is from the log file, but the UI gave this in a messagebox also:

Msg_Post: Error
Oct 01 08:39:12.852: vcpu-0| [msg.log.error.unrecoverable] VMware Workstation unrecoverable error: (vcpu-0)
Oct 01 08:39:12.852: vcpu-0| VCPU 0 RunVM failed: -2.
Oct 01 08:39:12.852: vcpu-0| [msg.panic.haveLog] A log file is available in "D:\Virtual Machines\Win 2003 R2 Standard -- MOSS\vmware.log".  [msg.panic.haveCore] A core file is available in "D:\Virtual Machines\Win 2003 R2 Standard -- MOSS\vmware-vmx-4128.dmp".  [msg.panic.requestSupport.withLogAndCore] Please request support and include the contents of the log file and core file.  [msg.panic.requestSupport.vmSupport.windowsOrLinux] 
Oct 01 08:39:12.852: vcpu-0| To collect data to submit to VMware support, select Help > About and click "Collect Support Data". You can also run the "vm-support" script in the Workstation folder directly.
Oct 01 08:39:12.852: vcpu-0| [msg.panic.response] We will respond on the basis of your support entitlement.

This error message seems to be reversible. I can turn on hardware virtualization and get the error. I can turn off hardware virtualization and get the VM to boot up just fine. Rinse, repeat. If this is just a coincidence, it's a strange one.

So, is there any way I can get my VMware VM to run correctly with the BIOS virtualization switch turned on? I'd really like to be able to use both VMware and XP Mode, if possible.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You can have both and also make use of VT-x but you can't run them both at the same time.

Take a look here:

http://edwinfriesen.nl/content/?p=222

The post above corresponds with my findings.

share|improve this answer

I think you can only run VMware xor Windows Virtual PC (which is what XP Mode is, I think).

The two don't go together. I think it has nothing to do with you switching on Intel VT-x support. XP Mode requires it, VMware should run with or without VT-x.

share|improve this answer
    
So are you suggesting that my problem might be that the Windows virtualization stuff is starting up early on my machine when I have the VT-x enabled, and that is what is keeping my VMware stuff from working? –  Chris Farmer Oct 1 '09 at 14:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.