Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running SUSE Linux Enterprise Server 10, SP2 (SLES10 SP2), and am seeing a large number of what support calls cosmetic errors being logged to /var/log/messages.

Does anyone know of a way to change the log level in the /var/log/messages file?

share|improve this question
    
Could not find the /etc/syslog.conf file. Found /etc/syslog-ng.conf I did not find this entry in the /etc/syslog-ng.conf file. –  Kam Oct 1 '09 at 17:42
add comment

2 Answers

Sure, edit /etc/syslog.conf. There's a line

*.=info;*.=notice;*.=warning;\
    auth,authpriv.none;\
    cron,daemon.none;\
    mail,news.none		-/var/log/messages

remove *.=notice or *.=info or tweak it as you want.

$ man syslog.conf

will give you all the options you can use.

Don't forget to restart syslog daemon for changes to take effect.

share|improve this answer
add comment

It depends on what syslog daemon you are using. From your comment about using syslog-ng I'd guess you should change this section in /etc/syslog-ng/syslog-ng.conf:

filter f_messages {
        level(info,notice,warn)
            and not facility(auth,authpriv,cron,daemon,mail,news);
};

Per the other comment, you could try removing "info,notice" on the "level()" line.

(I’m guessing you are looking for something specific in /var/log/messages and having trouble finding it among all the other stuff? If that’s the case, what you really ought to be doing is creating your own log file with exactly the messages you want. This might be a little tricky and require some reading of the dreaded manuals, of course.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.