Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My windows 7 x64 PC/server worked fine until I installed a brand new seagate SATA hard disk (2 TB). My first disk was a IDE Maxtor (250 GB). I tried to use it as a secondary drive leaving the maxtor as primary and, when I put the computer in sleep state, on wake-up the SATA disk is not recognized anymore until next reboot. Now I'm trying to set it as primary disk (I copied the old HD contents with HD clone), when the computer goes in sleep state, on wake up it doesn't see the disc thus causing my system to crash.

I tried the following:

  • BIOS update (Asus M2V motherboard) but the situation worsened as the system didn't wake up from the sleep (with both my HD's)
  • Reinstalling the drivers
  • Bios changes
  • Microsoft Hotfix KB977178 that seemed to address exactly my problem but gave me "The update is not applicable to your computer" message.
  • Disabling hybrid sleep but no results.

I also tried all the suggestions from this question Why doesn't Windows 7 wake up from sleep?. Still no results.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Ok, after huge amount of time spent in resolving this issue I found this solution:

  1. disable all sleeping modes in advanced power settings
  2. enable hibernate mode after 15 minutes

With this settings my PC hibernates itself and I am able to wake it up by Wake-on-lan, by keyb, etc... and finally all goes without issues.

Hope you guys found it usefull.

share|improve this answer

I had the same problem, and the hotfix that Microsoft put out wouldn't install for me, either, and sleep mode settings didn't help. I ended up installing custom (but certified) SATA drivers for my NVidia NForce4 chipset. That did the trick. NVidia never released Windows 7 drivers themselves, and the default Windows 7 drivers are part of the problem, so I had to go here for drivers:

http://www.win-raid.com/t15f37-NVIDIA-Optimized-nForce-Driverpacks-for-Vista-Win.html

The guy who put those drivers together deserves some sort of award, or at least a beer.

I'm guessing installing new SATA drivers for other non-Microsoft chipsets might work for others.

share|improve this answer

I think, you should go back to the step with the MS Hotfix.

This seems really to address excactly your problem. However, you have to download the hotfix according to your specific hardware.

http://support.microsoft.com/kb/977178/en-us

Let us know about the encountered errors with this attempt. Sometimes a solution is right at your feet, but not easy to pick up ;)

share|improve this answer
    
I'm quite sure I downloaded the correct file. I'll give it a try though –  Gabber Oct 30 '12 at 8:17
    
I get the exact same error message when trying the hotfix for Win7 x64 :( –  Goddchen Nov 25 '13 at 10:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.