Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I launch Internet Explorer, I get a toolbar popup:

screenshot

I always click No Thanks, but it doesn't remember the setting.

Specs:

  • IE 10
  • Windows 8
share|improve this question
1  
If you somehow can run custom CSS, you could use display: none on it. –  Tom Wijsman Oct 29 '12 at 22:11

3 Answers 3

You probably configured your Internet Explorer to either block or forget cookies. Google then always treats you as a new user and suggests "improvements".

One reason this might happen (and it did in OP's case) is that the option Internet Options -> Delete browsing history on exit is checked. Unchecking it might solve the problem.

You can either have privacy or convenience here: either accept cookies from google.com, or get used to the banner.

EDIT: Here's how to check if this is cookie-related:

  1. Dismiss the google popup in IE
  2. close and repen IE (make sure google.com is NOT your home page, or the test will fail)
  3. press F12 to open developer console
  4. go to Network tab
  5. click Start capturing
  6. go to www.google.com
  7. double-click www.google.com in the list of sites that appeared in the Network tab
  8. check if you have a "Cookie" request header (in the Key column). If not, you have cookies disabled somewhere, and Google should show the annoying pop-up. The cookie should look like this:how cookie should look
share|improve this answer
    
It's not that bad on www.google.com, though. On YouTube, the "Welcome to YouTube!" first-time-user dialog fills almost half of my screen! –  DzinX Oct 29 '12 at 22:20
    
The behavior doesn't appear to be related to which cookie settings I use. I lowed the privacy level way down, but I'm still prompted to install the Google Start app each time I open IE. –  mcandre Oct 29 '12 at 22:27
1  
I stand by my answer, because Google keeps asking me this when I clear my Internet history and restart IE. I modified my answer to include the steps that will allow you to make sure the issue is cookie-related. –  DzinX Oct 29 '12 at 22:59
    
@DzinZ You were right. IE was deleting browser history, including cookies, on exit. –  mcandre Oct 29 '12 at 23:03
up vote 1 down vote accepted

Lowering privacy options normally helps, but in my case, it didn't.

Fixed it (and many other websites): Internet Options -> Uncheck "Delete browsing history on exit".

This option was instructing IE to always forget my cookies; even if the privacy settings allowed IE to store cookies, every time IE closed, it would deliberately delete them.

share|improve this answer
    
Mark Dzinz's answer as correct :) –  Goran_Mandic Oct 29 '12 at 23:05
    
@Goran_Mandic His answer doesn't explicitly mention the problem: Deleting browsing history on exit was checked. –  mcandre Oct 29 '12 at 23:32
1  
His guess was next to correct- no one can know for sure what was deleting (or not saving) your cookies. Deleting browser history on shutdown seems like a really far-fetched possibility- it's something school computer rooms use- rarely regular PC owners. If you think your answer is the correct one- go ahead and accept it, but it just makes the whole problem and Q&A seem bloated, forced and not to mention self-imposed. –  Goran_Mandic Oct 29 '12 at 23:41
    
@Goran_Mandic In my case, it was definitely the Delete browsing history on exit option. I have amended DzinX's answer to specify this, but the community must vote to accept this answer. –  mcandre Oct 30 '12 at 12:34

Try adding google.com to the list of sites you want to allow to store cookies. This way you can keep whatever privacy setting you wish, with Google being the exception. This is done in the "wrench menu"/internet options/privacy/sites.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.