Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In iTerm2 (and OS X in general), hitting altT inserts †. How can I use the alt key to send the correct keystroke to iTerm2 ( in this case, in order to swap two words).

PS: Using esc instead is not the solution. Esc is not a modifier (keystrokes are not repeatable).

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Both iTerm and Terminal have preferences for using option as a meta key.

You can also use DefaultKeyBinding.dict to add support for keybindings like M-f and M-u to other text views.

share|improve this answer
1  
In my case, with the setting you are suggesting (Left option key acts as Meta), alt-t results in a question mark after a slight delay, but +ESC does the job. –  Antoine Lecaille Oct 30 '12 at 11:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.