Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install media centre on windows 8. I downloaded a key and installed it on my laptop with no problems.

When I try to install on it my desktop it informs me that the key checks out but then hits me with an error saying 'Something went wrong', 'Close this wizard and try again'.

After numerous reboots it always throws the same error.

Anybody have any idea why?

UPDATE:

2012-10-30 19:18:08, Error                 WAU    DoTransmogrify failed due to error 0x80070246.
2012-10-30 19:18:08, Error                 WAU    UpgradeSKU failed. Exiting.
2012-10-30 19:18:08, Error                 WAU    The worker process exited unexpectedly
2012-10-30 19:18:08, Error                 WAU    Something went wrong
2012-10-30 19:18:08, Error                 WAU    Close this wizard and try again.

UPDATE - CBS.log

2012-10-31 16:44:41, Info                  CBS    Exec: Processing complete.  Session: 30258995_853840040, Package: Microsoft-Windows-ProfessionalWMCEdition~31bf3856ad364e35~amd64~~6.2.9200.16384 [HRESULT = 0x80070246 - ERROR_ILLEGAL_CHARACTER]
2012-10-31 16:44:41, Error                 CBS    Failed to perform operation.  [HRESULT = 0x80070246 - ERROR_ILLEGAL_CHARACTER]
2012-10-31 16:44:41, Info                  CBS    Session: 30258995_853840040 finalized. Reboot required: yes [HRESULT = 0x80070246 - ERROR_ILLEGAL_CHARACTER]
2012-10-31 16:44:41, Info                  CBS    Failed to FinalizeEx using worker session [HRESULT = 0x80070246]
share|improve this question
    
is it the same key? –  Louis Oct 30 '12 at 10:12
    
@Louis - No, different key –  John Oct 30 '12 at 10:19
1  
If you paste this into Explorer a log file will open in a text editor: %localappdata%\microsoft\windows\Windows Anytime Upgrade\Upgrade.log. Can you post the part of that was written during the error? –  Louis Oct 30 '12 at 10:41
    
Have you tried Right Click "Run as Administrator"? –  Vian Esterhuizen Oct 30 '12 at 14:05
    
@vian-esterhuizen - no. this option is not available –  John Oct 31 '12 at 6:04

2 Answers 2

  1. Make sure everything is updated in Windows Update
  2. If you have a file called "ehome" in "c:\windows", delete/move it.
  3. If you have moved your "Users" folder to another disk (e.g. D:\Users) with a junction point, put it back first.
share|improve this answer
    
everything is up to date, there is no ehome file in C:\windows and I have not moved the Users folder anywhere. Also, out of curiosity, what is a junction point? –  John Oct 30 '12 at 22:40
    
A junction point is like an alias for one directory to another location. Apparently the installer doesn't like it. I had exactly the same issue and #2 was problem. Do you have an error in the file \Users\<username>\AppData\Local\Microsoft\Windows\Windows Anytime Upgrade\Upgrade.log ? –  cdm9002 Oct 31 '12 at 1:23
    
yes. it is in the edit. –  John Oct 31 '12 at 6:05

If you have a Junction Point the solution for the Media Center Pack installation's problem is simple (DO NOT COPY again the Users directory back to system partition but) follow these simple steps:

  • Launch REGEDIT (Windows+R, then type Regedit)

  • Searching "ProfileList" in Keys and Values, it goes to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList"

  • Change %SystemDrive% with the unit that contains your Users folder in Default, ProfilesDirectory and Public (LEAVE ProgramData AS IS) for example: %SystemDrive%\Users --> D:\Users

  • Start again Media Center Pack installation, it will work!
  • After machine restarting, you can put %SystemDrive% variable again inside the ProfileList Key Hoping to help for this problem. Best Regards!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.