Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently upgraded a computer from Windows 7 to Windows 8 using the upgrade assistant (keeping my apps and settings). It shows that 15 apps have updates in the store, but when I try to install them, the download progress never gets past 0% (they just sit there saying downloading). The same happens when I try to install a new application, it goes to downloading and never gets there. I have internet access, so that is not the problem.

Things I have tried so far after following every search result I could find on the topic:

  • turned my account into a local account and back into a Microsoft account
  • installed all windows updates
  • ran wsreset.exe a few times
  • rebooted several times

There are also a few other accounts on the computer (children's accounts), and they have the same issue - can't download new apps or update existing ones.

Any suggestions of what else I can try to resolve this issue?

share|improve this question
Have you checked event viewer? Anything strange there? – Peter Oct 30 '12 at 12:10

I'll provide an update. Suddenly, without me doing anything in particular (apart from asking this question on SuperUser!), about 10 of the apps started downloading, and installed quickly. I then tried installing some more and they hung waiting to download for an age, but eventually after an hour or so, got going and installed themselves.

So I don't know whether there is something wrong with my PC, or maybe the Windows Store is perhaps not coping with demand very well at the moment.

share|improve this answer
I'm voting for this as a possibility. When I was using the Consumer Preview I noticed similar behaviour, which went away by itself. – user3463 Oct 30 '12 at 16:09

protected by Community Nov 1 '12 at 18:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.