Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't get whats the problem but when i try to run the following command :

sudo apt-get update

I was getting an output of sort...

0% [Connecting to us.archive.ubuntu.com (91.189.91.13)] [Connecting to security.ubuntu.com (91.189.92.184)] 
0% [Connecting to us.archive.ubuntu.com (91.189.91.13)] [Connecting to security.ubuntu.com (91.189.92.184)] 
0% [Connecting to us.archive.ubuntu.com (91.189.91.13)] [Connecting to security.ubuntu.com (91.189.92.184)] 
0% [Connecting to us.archive.ubuntu.com (91.189.91.13)] [Connecting to security.ubuntu.com (91.189.92.184)] 

and so on... but unable to download anything... :(...

I updated my resolv.conf file and is as follows:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 8.8.8.8

the routing table looks like:

Kernel IP routing table                                                                                         
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface                                   
0.0.0.0         172.30.100.1    0.0.0.0         UG    0      0        0 eth0                                    
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0                                    
172.30.100.0    0.0.0.0         255.255.254.0   U     1      0        0 eth0 

My wired connection configuration is like this:

eth0  Link encap:Ethernet  HWaddr e8:9a:8f:0b:25:57                                                         
      inet addr:172.30.100.42  Bcast:172.30.101.255  Mask:255.255.254.0                                     
      inet6 addr: fe80::ea9a:8fff:fe0b:2557/64 Scope:Link                                                   
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                                                    
      RX packets:201591 errors:0 dropped:0 overruns:0 frame:0                                               
      TX packets:54761 errors:0 dropped:0 overruns:0 carrier:1                                              
      collisions:0 txqueuelen:1000                                                                          
      RX bytes:53827641 (53.8 MB)  TX bytes:7677456 (7.6 MB)                                                
      Interrupt:44 

And our institute uses a proxy server... when i try to ping that server it was pinging these servers but not the external servers...like security.ubuntu.com or some other site... I can access internet from my browser, but the software center is unable to download anything.

I have set the system-proxy also.. Plz help....

share|improve this question
    
Have you tried running traceroute us.archive.ubuntu.com? –  Matthew Brown Oct 31 '12 at 10:28
    
yea but still it wasn't working... –  nitish712 Nov 8 '12 at 9:49

1 Answer 1

The IP address starting with "169" in your routing table is an APIPA (Auto Private IP Address) and it should raise a red flag every time you see it. It means that your computer gave up trying to contact a DHCP server for a legitimate IP address. In a good LAN setup, I've found this is usually due to an unplugged patch cable. Also make sure your computer has the correct address for your DHCP server.

However "172" is a valid private IP address for your eth0.

Important: Do not edit your resolv.conf file!

Make the changes for dns-search, dns-nameservers, static IP address, subnet mask, etc. in the
/etc/network/interfaces file. To keep things simple, reboot after you make your changes or learn how to use ifdown and ifup

Your best bet is to search Google for your Ubuntu version and keywords such as "editing resolv.conf," "adding nameservers," and so forth.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.